App stopped working...Added a row to sheets and unique key id doesn't get created

It has worked for two years. Up to row 973. I type into sheets to add data and usually an id is auto generated and then it shows up on the app side. It stopped working today. Is there a row limit? I looked at my billing settings and I’m at private pro. Figured the row limit would be a lot higher. Any help is greatly appreciated…this is a critical app for me. Thanks.


I wonder if your team plan is on a legacy plan. Do you remember when you started paying for your plan? I don’t remember the legacy pricing and limits at all at this point, but 973 feels close to 1000 and 1000 might have been a limit at one time.

In the dashboard, in the analytics of the team, do you see any further information that might help understand?

Thanks for the help! I probably started in spring of 2021. When I go to billing there is a button Edit Plan. When I click it says “This app cannot be upgraded. Individual apps can no longer be upgraded. Please cancel existing app subscription to subscribe to a team plan.” Does that help.

Don’t really need a “team plan” whatever that is.

I just found that the Private Pro quota is 25,000 rows.

Sounds like your sheet isn’t syncing. Have you tried forcing a sync from the Data Editor?

Forced sync seemed to work! Thank you both for your fast response…very much appreciated.

Usually, you have to wait for several minutes to have a natural syncing and be able to see the latest updates in Sheet or Glide when you modify something.

If you don’t want to wait, you can force syncing by clicking on the arrow next to the data source in Glide Data Editor.

Other issues that can prevent from syncing can be a deleted table or column if the data was used by some features in the app (you have a warning icon instead of the sync arrow next to the name of the data source in this case, and a message that says that you have to remove these features before syncing).

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.