App slow to reflect google sheet contents despite Background Refresh being activated

Hi Glide Team,

Not sure if this is strictly a bug, but it’s definitely resulting in undesired behaviour so categorising it as a bug.

I’m on Glide Pro, and some of the contents of the google sheet powering my app is updated via a Google App script scheduled to run periodically. I have enabled Background Refresh for my app, which I understand is supposed to ensure that my app reflects the sheet’s contents to within a few (~3-5?) minutes.

Opening my app even a long time (i.e. definitely >15mins, but maybe even hours) after some of the data in the sheet has been updated, still doesn’t reflect the new state of the data. This seems to be kinda resolveable via repeated closing and reopening of the app, at which point it will switch to reflecting the updated data. My impression was that this is exactly what Background Refresh was supposed to avoid? Perhaps it’s related to some caching taking place in the app? What exactly is happening from a data-fetching perspective when the app is opened on a device on which it’s already been signed in from? Is there any way to resolve this?


(Happy to share app URL with Glide support via DM)

I have the same problem here with a pro app and background refresh enabled. Data take up to 15 min to refresh in the app.

If you look at the Google sheet change history, does it show updates every few minutes, or are there longer gaps between each history log?

If you’re referring to the sheet’s ‘Version history’, as accessed via File > Version history > See version history, then the updates shown there are spaced around four hours apart. Definitely not every few minutes.

In case it’s at all relevant, some of the functions I’ve written in Google Scripts are triggered to run periodically (every minute). This works fine for updating the data in the sheet - mentioning it in case there’s a chance it’s somehow interacting badly with the Background Refresh feature? Seems unlikely.

1 Like

Yes I was referring to the ‘Version History’. Thank you, I didn’t have the proper name in my head in my previous post. I have gone back and forth using Background Refresh in my app since it’s not entirely necessary in my situation, but I turned it on for awhile and there were frequent sheet updates every few minutes. It seems like it’s taken a break for the past few hours, so I’m not sure about the inner workings. Maybe it only queries for updates when the app is open??? Not sure, but in the past I have seen the version history showing updates around every 4 minutes.

I can’t imagine any scripting would cause a conflict.

Thanks for the follow-up, Jeff. Yeah, I also can’t imagine the scripts causing a conflict. My version history’s definitely only updating every few hours. Perhaps something’s causing my Background Refresh setting to not be recognised? I’ve definitely got it selected in my app’s settings. Perhaps someone from the Glide team can check behind the scenes to see what might be missing?

1 Like

What is also strange is that in my use case, I have a public app (pro) and an admin app {pro / email whitelist).

Users can create profile through the admin app, providing their email address. When a profile is created via a Glide form, a zap is triggered (gsheet) and I receive an notification by email.

Problem : it appears that often, if I connect the admin app to check and validate the profile, this said profile still not appear, even 10 or 20 minutes after I received the notification. I have to force close the admin app, and reopen it, sometimes 2 or 3 times, to get the new profile appearing.

So yep, even with background refresh every few minutes enabled, the synchro between gsheet and Glide is not always operating smoothly…

It might be worth monitoring the hidden metadata sheet to see if the auto refresh date is updating.

Thanks for the suggestion. Here’s a screenshot of my App:Metadata sheet taken this morning at 9:35am UK time. Looks like last updated around 10:30pm last night, and definitely hasn’t updated in the last few minutes.

Another totally far-fetched idea I had regarding what might be causing it is something to do with having selected to pay monthly for my Pro account rather than for a year up front. That would be a crazy bug, but mentioning it just in case.

1 Like

@psik If your app is not currently refreshing, could you please share it so we can take a look at what’s going on?

Hi @Mark, thanks. I DM’ed you the link to my app.