App opens to blank screen and does not load

Hi Mark, that is interesting. I was not able to find any information on how much Glides supports or where are restrictions? Can you share a link please?

Thanks Jeff, first link does not work, but nevermind. Found what I needed.

Interesting. It was there a few minutes ago, unless I was viewing a cached version of it or somebody is updating the documentation right now. I removed the link from my post. Glad you got what you needed.

one more

it says" Sometimes reloads of apps will timeout when the spreadsheet is very large. Generally speaking 25,000 rows is the upper limit of performance for Glide apps. Try to delete data in the spreadsheet that’s not used in the app, as well as empty rows and columns. " does the limit if 25k apply to just only a tab or to the whole spreadsheet?

I believe it’s the whole spreadsheet. I think of it this way…sometime Glide needs to transfer all of that sheet data from the google sheet to Glide’s internal copy of the data…especially when doing a reload. I think normal data syncing is in small chunks, but a reload probably pulls the entire spreadsheet. Also consider how many columns are involved. More columns means more data in each row to move as well. I really don’t know the inner workings of all of this, but I imagine Glide starts to run into timeouts when trying to pull and process large datasets. When Glide Sheets are released, this will give us the option of using sheets that are purely contained within glide, so this would help to eliminate this technical bottleneck between Glide and Google. In all honesty, I have done a test with up to 120,000 rows but maybe 3 columns. It worked for the most part but really slowed down my computer and phone. Mostly because I probably didn’t have any filtering and was trying to load all of that data at once (not a typical use case).

So 25,000 isn’t a hard limit, but a general guideline due to technical limitations. More is possible, but if it’s complex data, then you may have problems. 25,000 in a single sheet may or may not work, but you need to also consider the amount of data that will be syncing and caching to each device as well.



Now the problem is fixed and everything is running fine. Any info about the source of problem to know a little better what was happening?

Feliz día!

1 Like

Everything is fixed for me too since Saturday! I didn’t do anything so something changed on the Glide side?

Row count is at 29000. I know that’s a little high, but it’s for my city/state dropdowns (if anyone has ideas on how to do that with less rows let me know).

1 Like

So you tried to put all cities and all states into two choice components’ source values?

The city choice field is 29000 rows (all cities in the US by state) which filters by the state choice field which is just a list of 50.

Initially I had a zipcodes choice field, but that was 70k rows or so and it slowed things down too much. So now I just use a text entry for zip.

I think for the sake of your row usage you should let the city be a text entry as well, and possibly show a text entry combining cities of chosen state instead of using 29000 rows.

Thats what I was doing before, but needed some kind of data validation because people are matched based on city and state. Case sensitivity or adding a space or mispelling city has been causing mismatches.

Yeah that’s a concern, I wish we can have an autocorrect method for this, but 29000 rows would really limit your app’s performance.

Not much of a slow down, so that’s good. Right now the data validation is key, so I’ll keep as is for now until some solution arises. Thanks!

1 Like

I can report the same problem: Not load initial screen and goes blank.

It is solved by now?

My glideapp is stuck on the loading screen. It won’t enter the app. I tried using the web browser, but it is the same case. I used my other app, it functioned well. But this specific app would not. Can you help me on this please?

This thread is seven months old, please open a new issue.

I suspect this is your issue: Some apps continuously refresh instead of launching - #9 by david

Closing due to inactivity. This topic will be deleted in a few weeks if there are no more comments.