Add button not showing with filters and edit button in missing

New to Glide, so sorry if this is a simple question.
I want users to add records to the app, but only if they have the role of admins.
I created a users table and added myself. I have a ‘role’ column and there I write the relevant role. e.g. User/Admin/. So my role is admin.
Also created a filter to show the ‘add form’ only to users with admin role.
This is my screen, and I cannot see the + button.

In addition…

  • I don’t have anywhere to add the ‘edit form’ option. I see only allow users ‘Add form’ as in the screenshot.
    • Nor I have the ‘Delete form’ option.
  • I cannot control the fields to be added/edited.

What am I missing?

You need to view the details of one of your records before you can turn on the Edit/Delete option. It won’t be on the same screen as the Add option. Can you show the details of your Add Form filter?

What do you mean by

You need to view the details of one of your records before you can turn on the Edit/Delete option

Here is the filter details

I would think your filter for the ADD should work, but just make sure you have a matching record in your user profiles sheet. I know it’s kinda weird when setting it up initially because the builder doesn’t automatically create a user profile row for you glide email, so it’s possible that it may not be pointing to the correct user profile record, or it’s not pointing to one at all in the Glide builder. You may have to open the published url and sign in as yourself to make sure it’s creating the correct row in the user profile. Then make sure you are previewing as the correct user. You may want to try play around with the ‘preview as’ option one you’ve signed into your published app.

As for the Edit/Delete…your screenshot shows that you are still viewing the calendar list. There is nothing to edit when viewing a list because you are viewing all rows, so there is no way to know which row you want to edit. You need to click on one of your calendar entries to view the details. Once you are viewing the details, then you should be able to turn on the Edit option.

Thanks for the answer.
I am using a ‘test’ email and not my email as app owner. After a few refreshes and playing with the app, the filter has started to work and I can see the ‘Add’ button. Something with cache or app refresh I guess.

I understood your comment about adit.
What about delete? Still cannot see it.

You can add the Delete option within the Edit screen.

1 Like

Thanks a lot.
Now, after a couple of hours of trial and error, it is clearer.

1 Like