Conditions on actions

Hello plz help if you know I really need help. This is for school project.

So I finish building my app however, people are allowed to edit it from anywhere and I don’t know how to fix it to make it only I can edit the app. If you know how to solve this, please contact me as soon as possible because I have been trying for a week. My app is set to public because everyone is allowed to access it, but I just need to take out that edit feature where everyone’s allowed to edit it

Hello, thank you for the reply. I did do that. The only action I allowed is that users are allowed to add items, but not allowed to edit items. However, some of my navigation is custom and doesn’t have a action button. What do I do then?

You need to set conditions to show certain things if the signed in user is you.

Is it possible for u to show me how I could that like the exact coding?

It’s hard to say for sure without knowing more about how your app is set up. Any component can have a visibility condition applied. Any edit ability can have a condition applied.

You need to show us how users are able to edit data.

How do you open the edit form? That’s where you set the condition so people can’t open the edit form unless it’s their row.

There’s a button that said edit and so I clicked it what codes do I put in to make users not edit bc idk how

Like if I send u my app rn u can see u can edit it

Where is the button?

Go to the layout editor. On the left, select the component (collection, button, etc.) that has the action. On the right, go to the actions tab. Select the “Edit” action. Select “Add condition”.

You can do the same directly in the Actions editor if that is where your action lives.

Your condition could be something like “User Profile Email is [your email address]”


Hello I did what u said and when I logged in as a user I was still able to edit it plz help me w this

Thank you

I’m not sure, but it might not be working because of the fact that you are using email anonymisation.
Try adding a Role column to your User Profile table, and then assign yourself a Role - eg. Admin.
Then change the Edit condition to “User Profile → Role is Admin”
That should work.

I can’t tell from your screenshots, but is that a Title or Action Row component that contains that edit button? That’s where you should be adjusting permissions. Not on the collection itself. Click on the component that contains that edit button and show us how the actions are set up for that button within that component.

As you can see it still didn’t work idk why, the edit button is still there and I’m sign in as a “Locals”

It would be more informative if you provide a screenshot with a full screen. The left panel contains the components and the right panel only contains the settings panel. The issue becomes more complicated if we have to guess which component is selected in the left panel.

1 Like

This is when I click the edit button ^^

I’m not sure where the edit button even located tbh but maybe u can see it??

I get that buh I’m doing it on my phone so bare w me I’m still trying to get the whole screen

Thank you, it’s clearer now. However, from the screenshots above to the last one, they are slightly different. Which one is the issue you’re referring to? Is it the Title component, collection component or is there another one?

There’s something strange I noticed in the user section. Why is the user you marked as admin labeled as “coordinate”?