502 Bad Gateway - nginx/1.20.2 - App inactive

Hello everyone,

Our app is not responding since yesterday morning, with an 502 Bad Gateway error.
The Glide server seems to be active, so I don’t know where to look to solve the problem.
I watch other subjects but I saw that this error never stay for more than one day.


On our app management, I see no red flag…

Did you have the same issue somewhere or any idea ?

Thanks for help,
Great day

Check your custom DNS settings, both on the Glide side and your provider side. Make sure you have green ticks in the Glide config, and that everything matches up correctly.

1 Like

Thanks for your answer !
It’s an application created by another person, so where do I find DNS settings in glide and where can I find the info about “who” is my provider ?

Great day, thanks by advance

Below is the documentation on configuring a Custom Domain in Glide.

By provider, I was referring to the provider that manages your domain name.

Anyway, if you can find your way into the Custom Domain settings, and get me a screen shot from Step 3, I might be able to advise further. It should look something like the below:

CleanShot 2023-07-09 at 20.26.34

Just one more (possibly silly) question - are you 100% certain that https//:appli-lab.org is the correct URL for your App?

1 Like

I didn’t find the custom domain page because i saw this option was on business plan, we are on free.
But, I discover that the link of the app was not the same, now it is “https://applilab.glideapp.io”.

Did glide change this free features to business ?
Because I explain, it’s been like 4 years we have this adress “https://appli-lab.org”, we print QR code and like 1500 peoples are using it. Do you know what changed ?

And most importantly, the new link from above do not recognize my mail address (and this was the address I used to connect, she is in the excel files with the others address, using “Private sign-in : Limit access to email in table…”. So in fact, I cannot use the app still.

I don’t know what to do

Thanks for your help, a lot
Great day

Okay. As far as I am aware, Custom Domains have never been available on free plans.

So what I suspect is that whoever created your App would have setup some URL forwarding such that https://appli-lab.org would be forwarded to https://applilab.glideapp.io

And it seems that forwarding broke. Perhaps the Nginx webserver crashed, or maybe the configuration was changed.

Are you able to contact the person who originally created the App for you? That would probably be your best option to get this all sorted out, as they will know how it was originally set up, and what to do to fix it.


Thanks for your answer !

I think I might see the real problem. With a lot of research, is saw that we were on “pro” for like 3 years. Our services didn’t saw the last bill and so we are now in free plan.
When I checked the email address of the apps, i also see a mail from March 2023 who speak about “unlimited rows for excel is now done”. Now it’s only 5000 or 25000. We had a lot of rows. I think we were still in this plan with unlimited rows because we subscribed for the year, now, we need to clear rows.

So we’re gonna try to be pro again, and clear some lines. See if the services can be restart with good settings.

I keep you in touch.
Great night

1 Like

Hi again,

So, we were on free plan because our billing didn’t go for this June 2023. Now we’re back in starter. But the app is still not working, it’s very strange. I duplicate her in my starter team to do some test and remove some lines etc… but :

  • When I click on the link of the app, I’m coming on the page of the app but she don’t recognize my mail address “Mail is unauthorized”. This was working fine next Friday, and from the beginning. I checked, my address is indeed in the excel as admin. It’s like the excel wasn’t communicate entirely with the app.

  • When I pass her in public mode, I’m not arriving in the main page ! I arrive in another annex page, and it’s like most of the data isn’t there. But it’s in the excel, I checked again.

  • I checked that we were really under 5000 rows, and we are in the excel…

The link of the test : Copy of IFs

I really don’t know what to do right now to get her working. I don’t understand why it’s not working like that.

Do you have an idea to help me ?

Thanks a. lot,
Great day

Edit : Oh, and in the making page of the app (where we can see the app with the modification we can do etc), it’s all ok, she’s like she need to be (see pictures).

Okay, sorry to reply again, but I managed to connect to the application like usual, but not using my mail. I used the mail of the app, who is on the top of the list as admin, and it worked fine. But it’s not working for the others address bellow (200).

I have a lot of admins and user as “Voyageurs” in fonction. Is that a problem with the “Private users” mentioned in the pro pack ? Searching some leads…

Sounds like your privacy settings might be off.
Go to Settings->Privacy and check there.
If you can’t get it working, show me a screen shot of the settings.

Can you show your usage for the app?

Hi, I’m back,

So, i manage to get the application working again.
The problem was in fact the Privacy setting who was set on “user” and not “Email in the table”. Now it is and everyone can log-in ! Incredible.

But I discover a new problematic. Now, the app say “This application as reach is month users limits”. In this version, we used role, so everyone was a “Voyageur” or a “Journaliste”. It never happened before.

Do I need to simply erase the role for everyone except the 10 I want, or did everyone in the email table is considered a “Private user” by Glide ? If yes, it’s going to be problematic…

Thanks a lot for your help !

Jeff, this is an application to show the next intervention and the files of them to our students for a formation :slight_smile:

It depends on how your Privacy Settings are configured, and whether or not you use roles. Have a look at the below first, and then let us know if you need further clarification.

I meant the usage limits graph that shows which limits you have exceeded.

I’m guessing you were on a grandfathered legacy plan. When payment lapsed, you lost that grandfathered plan and now you are on a new plan using new limits. That’s why I want to see your usage limits to see what’s been exceeded and to determine what your plan limits are.

1 Like