Where is the 'Complete Prompt' action to be found?

Loved the video from David, Glide CEO posted on LinkedIn recently.

Can someone help me find the OpenAI command? When I search for the action ‘Complete Prompt’, or even ‘OpenAI’, the action does not appear for me to select…

1 Like

Only for pages… When you login to the editor there should be a prompt that says “new actions try/ dismiss”

Maybe refresh or try a different browser all together. I think they may have limited the number of participants to new actions.

Edit: in your screenshot it shows openAI>complete prompt… be sure to enter your api key.


Ok, I made some progress. I had to

  1. accept the new features when logging in to Glide, and
  2. I had to go and get an API key from OpenAI.

I did those 2 things and I could now see the new integrated actions. However, when I added a button with the Complete Prompt action, it didn’t work. I was sure to enter my secret API key, I added a column to receive the prompt result and put a simple custom question in the prompt field, e.g. What is the animal in the Porsche logo?

results in:


Any thoughts?

Fix coming in next release. Sorry for the disruption


Thanks Jeremy - Any ETA on that?

Should be live now let us know any other feedback

Ok just tried it and now I get this error:

With a bit more fishing I suspect I have to set up a payment method for the API on the OpenAI website - do you agree?

From what I can tell, it will cost ca. 0.02 USD per 1000 tokens, where 1 token is a fragment of a word, so 1000 tokens would be approx 750 words returned by the API prompt. I think you pay for what you use with no minimum per month.

Does that sound right?

I’m not sure which model Glide is using under the hood, but if it’s gpt-3.5-turbo then it’s $0.002 / 1K tokens.

Please check: OpenAI API to see if you have exceeded your monthly limit (you can set that limit manually).

Hi Jeremy,

Im running into this issue when pasting the API KEYS. When I click away it seems to be reverting this back to something else by default. Please see video. API Paste Error(?) - YouTube

Paste it, wait a second then it should be good to go. Did you try running the action after?

Indeed, I have tried running the action - now an error i’ve seen floating around. An ‘exceeded quota limit’ error.

As far as I know I have not used up any?

Check your open-ai dashboard for your usage with them

I can confirm that the dashboard says I have not used any tokens. Do I have to be on a paid plan?

Hmm weird… Try going through our main support channel so we can get a better replay of your environment. Also maybe check back once open comes back online - they’ve been having issues today https://status.openai.com/

OpenAI is a paid API. Get your credit card on file.

@Jeremy we better add this to the error.


Lol Problem solved. Nice work team @david @Jeremy

@david @Jeremy Does the ‘Answer Questions about a table’ have a limit for amount of rows it can read? My table has about 1500 rows. And i’m getting the following error. Seems to be able to answer questions about my user profile table which is much less.

I haven’t tried that specific integration, but do you have a lot of columns in your table?

I have manually asked CHATGPT to analyze and summarize tables of data. It worked well but rejected tables beyond a certain row size. I believe it was around 75x30 but I never checked in detail. I expect the limit is growing rapidly.