Love the new OpenAI features. Is anyone else having a prompt problem?

My App/Pages support link:

Describe the bug:
I am using the OpenAi action features. I keep getting an error that my prompt can’t be completed. When I use “Complete Prompt” and “Send Message to Bot” the other prompts work fine. Is there something I am doing wrong? I have tried two models gpt-3.4-turbo and **`text-davinci-003.
Expected behavior:
I should get results.
How to replicate:
I created a “create about us content” button. Which reads a prompt field called “about us prompt” and the results filed is “about us”
Link to demo recording:
Vidyard Recording?

If you shrink your max length from 700 to something smaller does it work? Also try removing the model and using the default one. Also check your quota with open ai, you might have busted through that.

Cool use case btw.

Hi Jeremy,

Nice to meet you! I understand you built this widget. Awesome job. This is going to be amazing once I get it working. Thank you for building it! I had been using Zapier which wasn’t going to scale.

I tried removing the model and lowered the token count. It still doesn’t work. I am also not near the limits of OpenAi or Glide. Can you screenshot how you have the widget and tables setup for “Finish Prompt” and “send message to bot” or can we jump on a screen share real quick?


I also checked and I can run all the other OpenAI functions. It is just those two that I am doing something wrong.

Thanks for bringing this up! Got a fix in the oven now :construction_worker_man:

Oh Great. Do you know if it is a quick fix or how long it might take. I am not in a rush or rushing you. If I know about how long it will help me decide if I use this option or another option for a demo I have Monday.

Looks like prompt is working. Are we supposed to set up the tables a certain way for the Chat Bot option?

Yea have a table with those columns “Role”, “Content”, “Session ID” and “Timestamp” (where timestamp is a date / time column) and attach it to the action.

Can you screen shot your headers of that table and the way you have the widget setup? I am missing something when I do it.

There might be a bug with an empty table, if so click new row before running the action for the first time

Sat with askjoeai and he brought up some other bugs after setting up his use case. Just finished fixing those and they should be coming through the pipe next release:

Adds prompt (system) field for chat bot to direct the conversion instead of adding it in your chat history.
Adds a workaround for picking out the time stamp (rather than timestamp) field in chat history.
Blank chat history table were giving some weird error message. The work around was to remove the first row instead of add it. But will fully fix this with this release.

Keep updating us with comments/questions/concerns/feature ideas.



I’ll keep you posted. So far I have been able to progress nicely. Thank you for your help!

Couple potential bugs.

  1. Bread crumbs aren’t working.
  2. Strange text in results.

Here is a video

Same issue with Complete the Prompt — not able to change the model