Users's email address not being loaded when form is submitted

I have a form using User Profiles as the source. I just want to capture the users name and email address. On submit I Set Columns Name to entry field Name and Email to the Special “User’s Email Address”. The Name gets entered in the User Profiles table but the email does not. I am on a Basic Plan - does this make a difference?

Are you sure you’re signed in?

Another thing - you shouldn’t have a set columns action that sets name as ‘name’, that is already done automatically. And for more efficiency with the ‘logged in user’s email’ going into the ‘email’ field, I’d recommend a screen column for that instead - you really do not need a set columns action!

Thanks for the reply

Yes, I’m definitely signed in

I removed Name in Set Columns and that still works fine loading the name into User Profiles but I whatever I do to try and get the user’s email, nothing works, Are you sure that the Basic Plan I’m on doesn’t restrict this working?

By the way, I created created the User Profile table well after setting up the rest of the app



The basic plan does not restrict the fields you can use in the set columns action.
@ThinhDinh Do you know what’s happening here?

Does it work when you try it in the app, and only not work in the builder?

Have you picked a user to Preview As?

No plans should restrict the fields used in set columns.

1 Like

Thanks for the help, David

It doesn’t work in the App or the Builder

By “Preview As”, do you mean “Viewing as” - if so, yes I’ve tried it with my Google login and some “Viewing as” users. As I said in a previous email, I did not start out with a User Profiles table, I only added it later, Could that be an issue?


Can we know more about your use case here? Why are you setting the signed-in user’s email address to another row in your User Profiles? If you’re trying to update the user’s profile then it’s not the way, it will add a new row.

Problem solved

Because I did not set up User Profiles before logging into the app from my phone, my email address was , of course, not added to User Profiles. Later when I added User Profiles my phone login details had already been stored in the system, and I assume that Glide skips updating User Profiles when someone has previously logged in. In reading all of your emails, it occurred to me to create a new Gmail login and see what happened. Well of course, the new login email was stored in User Profiles and my futile attempts at storing another way are no longer required. Thanks for nudging me onto the right path!

By the way, is there a reason that User Profiles is not created automatically - I can’t imagine why anyone would not want to use “Visibility” options



1 Like