Special value "User's email address" not working anymore

Hi, I have an application in production used daily by tens of users since 3rd of Jan.
Today users reported me that something was going wrong.
I found that special value “User"s emai address” is not set anymore.
I use it to identify who has made the udpate of a record but this field is now left as blank…
Any idea ? Any recent change ?

Try using
User Profile → User Email in the form

Hi, it does not work neither…

If I display the User Profile / User Email in a field the value is Ok.
But when I edit au form, the special values in the COLUMN section seams to be empty (user’s email adress or any user progfil information). They do not populate target field when the form is submit. I also tried to copy in the clipbord the content of these special values using ON SUBMIT actions but the clipboard remains empty…

Do you have user sheet activated?

Can you screen record the issue?

User Sheet Activated ? I guess yes as I have App:Logins Tab in my Google Sheet with all user emails.
Here are the screen shots (simple app to debug the issue I have on the live app):

  1. In screen 1 we can see that my user profile is known by the app.


  1. If I display in the component the value of User Profil - BenMail, I have the email adress of the user.

  1. I asked the User Profil - BenMail to update the BenMail column of the current record after Submit

  1. After Submit I can see that column 4 (Commentaire) has been update but not column 1 that should contain BenMail

Thanks for your help,

It looks to me like your User Profiles are not correctly configured.

Please go to Settings → Users & Authentication, click on “Edit User Profiles”, and take a screenshot of what you see in the right hand panel. It should be something like this:

What if you choose the “Signed in user’s email” value instead of “User > BenMail”>?

It seems to be ok


Hello ThinhDinh if you refer to the Special Value “User’s Email Adress”, I already tried this and it does not work…

I notice that your BenImg column is a Link Type column.
Please change that to an Image type.
I’m not sure if that will make any difference, but it might.

I tried, but I still have the same result…

If this issue still persists, please get support from within Glide while the app is open by selecting the “?” button at the bottom right. That will bring you to a support page, which currently has an “Open Support Ticket” link.