Users see blank screen after sign in

Hello everyone, I have this app:

But there is a problem. Once user sign into an app, he sees nothing. Just blank screen with the name of the portal. When I test it on backend and select view as this specific user, I can see everything right. Admin users works correctly but ordinary clients can’t see anything… Tried different users, computers, cleaning cookies. When an admin signs in, everything looks good, the problem is only with users… And they should only see their profile, nothing else. (Checked visibility settings also)

Recording of the problem: Screen Recording 2023-01-12 at 13.56.02.mp4 - Google Drive

You video demonstrates the behaviour, but doesn’t provide any information that could help debug the issue.

You said that you checked visibility settings. Did you check tab visibility settings, or component visibility settings? What did you find? Can you show a screen shot please?

Can you also provide a screen shot of your User Profiles configuration, as well as your Users table.

Of course, here are screenshots: Glide screenshots - Google Drive

(As a new user I am not allowed to embed more than 1 image, so it is google drive link…

Since it is user profile page, there is no general visibility settings.

None of the basic components on this page has visibility restrictions.

Okay, thanks.

One thing I noticed from your screen shots is that you are using the same column for both Name and Image in your User Profiles configuration.

So the first thing I would suggest is to fix that. You need to create a separate column to use for Image, and make sure it is an Image type column.

I’m not 100% certain that will fix the issue, but it might. So give that a try.

Hi, yes, that was a mistake I just fixed but it did not solve the main problem. :confused:
I am still not able to see anything as a user…

You only showed visibility for one of the containers on the screen. Can you show visibility for the tab. I would suspect that you have tab level visibility that is set.

It is user profile screen. As I know, there is no option to hide user profile page. At least I don’t see any visibility settings on this particular tab.

Yeah, I missed that it was the user profile tab. I don’t see any way to do tab visibility either, so I agree with you there. Nothing is jumping out to me. I assume when you sign in as an existing user, it’s still a problem? Or, is it only an issue with brand new users?

I see that you are using a google sheet as the user table. I seem to recall in the past that there was a delay in the row being created for brand new users, and people had better luck with glide tables. That may have been fixed though. Especially if you are signing in as an existing user.

Is there any chance that you have any column in your user table that has row owners applied, but isn’t visible in your screenshot?

1 Like

Thanks Jeff for spending time with my problem. Feels good to not be alone in this especially when time pressure in this project is a thing.

I don’t have any column with row owner assigned in the whole sheet… The problem is with every user no matter the age…

Now I am wondering whether I should try to change the whole user table from Google sheet to glide table…

Have you checked the settings for access, sign in, users - make sure that you haven’t set it to users in the users table or only members in your team etc etc

There also used to be an issue with google sheets where the new user details would be added to the last row in your sheet (for example row 500) then there would be many blank rows that don’t show up and possibly affect other calculations thereby making nothing display, including the new signed in user, i used to have to delete the blank rows and it usually corrected itself, unless you have an incorrect array formula that keep adding blank rows.

Here is the screenshot from google sheet table. It looks like there is no empty rows. The only difference I see is the colour of the last rows. These rows are the rows I am testing the app with and they were added straight from the platform. Can this be the issue? I don’t see any reason for it.

Here is the settings I have.

For some reason I cannot post another link to set of screenshots.
So just add dot behind “google” in this text

Also it may be useful for this topic, but I am also experiencing another “weird” stuff happening in my Glide account. For example, when I set an action to send an email after button click, there is no email being sent after I click on it.
It used to work a week ago… I am kinda wondering what may cause this and whether there is not some weird source for all these problems…

I see your google sheet row number 143 is blank, there should be no blank rows at all, just delete that row.
Another thing is that you have got a private app with “anyone with an email included in a table” Klienti A - is that the Users Table
What if you select the “users in the users table” option?

All the rows after row 142 are blank. It is an endless google sheet.
Yes, Klient A is the users table.
I’ve changed the setting to “users in the users table” and nothing changes…

It might be related?
I have found that when your user profile page isn’t set up correctly to start with OR you have added and deleted rows then re-added the same email, it doesn’t always pickup the correct row. Ideal is not to tamper too much with the User Profile sheet.

In my experience you cannot have blank rows on a user profile page.
Glide will create a new row when a new user signs in, and if you don’t need to add any more users then just delete the rows as they are not needed.

These blank rows aren’t shown in glide databases as you can see here:

I don’t even know how would I delete rows from Google sheet.

I’ve created a user with new email which was never used before and the problem persist. :confused:

To delete the rows on the google sheet, just highlight the row numbers on the left panel that you want to delete and then hit delete.
Click on 143 in the side column, and hold shift and command/control then arrow down to the bottom, once highlighted click delete.

Another best practice is to not have so many blank columns and cells if possible, but the fact that you have Row ID should help with indexing.

Okay, rows deleted, you were right.
These blank columns won’t be blank, they should be automatically filled once I finish the script with programmer.

However problem persist. Do you think it would be good idea to switch user table to glide from google sheets?