Title on cards screen not respecting filter

I have a screen set as “cards”, and when I set the Title to the (current record) “date”, it is showing the date from the wrong record. Everything else on the screen is correct. I am filtering by a text date of “January 28” from a column, but you can see it picks up the first record in the table, which has a date of “November 21” – and all the other values which could be inserted in there all seem to come from the first record rather than the record that shows on the card.


Even worse, when I click the button to “close this window”, I use a custom action “set column” to set the columns in ‘this row’, and it is setting the values to the first record in the table rather than the record that is displayed on the card:

I have another app which uses the same (shared) table, in which both these things work correctly. It is the ‘primary’ app, which I first used to set this scenario up.

OK, in this case, you need to filter on the main screen as well as on the inline list for it to work correctly. How did I do it right the first time and not know what I was doing?

Leaving this here in case someone else has the same ‘issue’!


I feel like something’s wrong here. You should not have to filter on the tab level.

So this is a details screen, on its parent level, where you have a button and an inline list?

1 Like

Yes. When I looked at the screen that was working, it had the filter on both the parent tab and the inline list. I was surprised, also; that I had thought to put it on both. When I put together the second screen, I expected it to work with just the filter on the inline list. But since the button and its actions are tied to the parent tab, I guess I can kind of see the point that it doesn’t know what record you’re on in the inline list. However later today, I was setting up a relation, and I really wanted (in the relation) for the last item (by date) to be shown first. SORT is not an option when setting up a pure relation; only when associating that relation to an object.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.