SWITCH functionality

I am trying to set Switch functionality to be User Specific but I am not seeing the User call out at the bottom of the Columns list. I swear it was an option previously, so I feel like I am losing my mind now. The switch ends up toggling the top most row in the User sheet. Here’s what it looks like.

What am I doing wrong?

YT video

Looks like you just need to add a filter to your screen: where email is signed-in user


It looks like you don’t have an owner row column that automatically selects the authenticated user. If this is not the case then you should at least set a filter in the detail to select the active user. Otherwise it is normal that you are positioned on the first record.


oops I answered at the same time as you :sweat_smile:

Damn… Thank you - rookie mistake. Setting Email is User Email fixes it

1 Like

Don’t worry, it happens even to the most experienced, sometimes :grinning_face_with_smiling_eyes: