Sharing not working

Using the “Invite people to your App” pop-up, to bring a co-worker in. She receives the invite, scans the QR code, and inputs her email — we’ve triple-checked that it’s exactly the email I put in the pop-up, and she’s denied access. What am I not seeing?

I assume you have checked for trailing spaces and no capitalized characters?

Yes, thanks. Nope, exactly the same. As a workaround, I added her email to the user table manually, and set “Private Sign-In” to “limit access to emails in table,” and that took care of it for now. Still a bit of a puzzle why it didn’t work the other way.

What were your privacy settings before you changed them?

1 Like

Had it at [organization] team members only. Perhaps that’s the issue? Saw no additional way of defining the organization when I input the info in “Invite people to your app” dialog.

The team member setting means that users need to be listed inside your Glide team as members which in turn means they have the ability to edit the app and see all tables and data in your app. They will need to use there email to create a Glide account and then they are in your team.

You probably want instead to use the “Limit access to emails in the table” option.
Screenshot 2022-06-11 2.28.58 PM

1 Like

Right, OK. As I do need for her to be able to edit the app, see all the tables, etc., we’re back to my original question. I started the process by adding her to the team. When she tries to sign in on mobile, she gets the message I included in the first post.

Given your last post, I went into team settings, deleted her (her invite was still pending), and added her again. As before, she received an invite (the sender is “testuser,” which looks a trifle janky — perhaps that tells us something?) to sign in. Upon doing so, a pop-up informs her to confirm her email, but no email comes. Upon choosing to resend the confirmation, she is taken through the steps of setting up her own account, complete with inputting company info, etc., though no confirmation email ever arrives and no connection to our team is ever established.

Having gone through all that, she still shows up as ‘pending’ for me, unsurprisingly.

It’s baffling, honestly.

Not sure what’s going on. If you haven’t yet, you should create a support ticket:

Will do, @DarrenHumphries. Thanks to you and @ThinhDinh for the input!

1 Like

Does it work if she completes the registration process for Glide before you invite her to the team?

Does she use a different email provider/email domain compared to yours? We have seen cases where an email domain blocked Glide from sending the verification email, or put it in the spam folder.


Yes, that worked — she completed the registration (and all of the confirmation emailing worked) and then I invited her again. Everything worked as expected.

Not sure whether to mark that as a solution — it would have been a lot easier to invite her without her having to sign up first, but thank you both for the input!