Set column doesn't update GSheet

I have a form that on submit changes a column in a relation sheet.
The value changes in Glide table, but it doesn’t changes gSheet value, even several minuttes later.
The form writes fine the values both in GSheet and Glide table.
My app’s URL:
On submit action:

Glide Table:
Gsheet image: image

1 Like

You have it set to change a relation row. Although you have the option to select a relation column I don’t think that works in that manner.That needs to be pointed at a definitive/static row.

I haven’t played with it much, but it’s my understanding that you can in fact use the set column action to update a column value through a relation, but only as long as it’s a single relation.

It appears in the screenshots above that the column is getting set, but it’s just not syncing to the sheet.
Two things I would check first:

  1. Does the reload button have a yellow triangle?
  2. Does data sync if you manually update it through the data editor?

My immediate thought is that the action may not be triggering glide to send the update to google because you are updating another sheet other than the current sheet you are on. It may sync eventually, but for some reason it’s not happening immediately. I would try adding a second action that updates a value in the current (parent sheet of the relation) sheet. Maybe glide is only looking for updates in the current sheet instead of the related sheet and because of that, it’s not triggering the glide process to send the updates to google.

1 Like

I tried this after I responded and I still didn’t have any additional data added. It would be nice if it did but mine did not work as well. Maybe it is supposed to do this but Imy first attempt when I saw it a while back didn’t work and neither did today’s attempt. @Jeff_Hager let me know fi you figure it out please. I wouldn’t mind using this instead of scripts in some scenarios.

1 Like

That’s what I think too. If it is this way the option set column to a relation shouldn’t be avaliable on submitting a form.
For now, I’ve found a solution by setting a column on the form sheet and whith a join column and a ‘if includes’ condition.

@profechef @Drearystate would either of you have a small demo app that I could copy where you have this situation set up, but it’s not working? I just want to make sure I’m testing the exact problem.

Like I said, I haven’t tested or used this feature much, but testing through this myself, here is what I observed (all this was done in the staging environment):

While working in the editor, I was able to have a button with a set column action to write through a single relation to another sheet. It worked correctly. While working with the published app, I was not able to get the button to work at all.

While working in the editor, as well as the published app, I was not able to get the set column action on a form submit to work in either situation. I could maybe see that the underlying issue here is that the action runs before the form completes writing to the sheet, so at that exact moment, the relation on the new row had not been established for the set column action to do anything. So in my test @profechef, I was not able to exactly duplicate your issue where it is updating the glide database, but not the google sheet.

From what I observed with the action directly on a button, I can see that there is definitely a bug with the action not working at all. With the action on form submit, I’d say it’s also a bug, but most likely due to a timing issue where the action is run before the relation is established.


Here you have a demo.
With the first button you type the title of a new homework (o whatever you want). At the same time the column “Ultima” (last) is set to TRUE (hidden) and a new “button” appears (fake -> it’s a relation list) so you can add several items to the homework. If you want to add another item then you choose “Si” (YES) . If it is the last item you choose “No” and the column “Ultima” is set to FALSE using the relation. The button “Añadir” disappears, but the Google sheet doesn’t change and the next time you add a homework there will be two last ones (“Ultima”).
Set column relation Demo
By the way. Thanks once again for your time

1 Like

The link doesn’t seem to be working.

Solved! Now the link works

I can definitely duplicate the issue and it definitely seems like a bug.

I tested it by first adding new homework, then adding new items to that homework. The first item is set with ‘YES’ to add another, the second item I added is set with ‘NO’. Like you mentioned, I can see the value change through the set column action on the relation in the glide data editor, but that change does not sync to the google sheet, even if I click on the reload button, it still doesn’t sync to the google sheet. I also did the same test when viewing the app with the published url. It appears to work, but the glide data editor does not show the value in the Rubricas sheet being changed at all. In both tests, if I refreshed the browser to reload the glide editor as well as the published app, the Ultima value is set back to TRUE.

This is my guess as to what is happening. I think in the glide editor and the published app, the value is being set, but glide must not be recognizing the change. In the glide editor, it is not syncing to the sheet. In the published app, it is not syncing the change to the glide servers at all. I think it is setting the value locally on the device so it works temporarily, but not getting set on glide’s database, so when you refresh the browser, it resyncs from the database and get’s set back to the previously set value. I think this is definitely a bug and should be submitted to along with the support url. This explains the problem I had when trying it in my test app and the same issue that it appears others have had in other posts that I read. @Mark @George_B just a heads up if this comes through your support system.


I am having same issue…please share the solution.

We’re working on it. It’ll be fixed on Friday.


I didn’t solve the issue. I solved the wrong link. Sorry for the misunderstanding.
I found an alternative way to get the column changed without “Set column”. I explain it in this post Set column doesn't update GSheet - #5 by profechef
Ask me if you need more details of this solutoin

@profechef ok. thanks. Our application is different.

I solved by re-doing the whole programme flow…What I noticed is that I can set columns through the relation BUT cannot clear it. However, I can clear a “Boolean” cell consistently. This helped to minimise the changes that I need to make.

I take note that @Mark mentioned the issue will be solved by Friday…

cool, waiting for this update. I was following I was facing this issue as well.

it only remains to wait

I have suspected this for some time and think this issue persists. I’ve failed to get on submit actions > set column working on single relations. I’ve shared these two scenarios with @George_B previously. Maybe there’s a connection.

Scenario 1: Using set columns to clear user-specific date values in Sheet A, after they’re submitted through a form to Sheet B

Scenario 2: Form button on Sheet A submits to Sheet B. Sheet A & B have relations to Sheet C. I’m able to access rel_C to update a column in sheet C with current date/time but nothing happens.

I tried to think of a way to stagger the actions but wasn’t successful.

@profechef was this resolved on your end?


I answered in a previous post in this thread

Hi @Mark is this solved?
I seem to still have the issue.

In my case from a Submit new form I can add a custom action with Set Columns and get it to work but my custom action in an ‘Edit’ existing form I cannot get it to work.

Closing due to inactivity. This topic will be deleted in a few weeks if there are no more comments.