ROW IDs ! Urgent issue with Glide

Row ID no longer synchronizing with google sheets. what has happened. there seems to be a bug with Row IDs in Glide.
Even glide itself is not recognizing RowIDs. I lookup a RowID of a row and it returns an empty value after a certain row

has anyone faced something similar today or late last night. We use Glide daily to process hundreds of orders… this is the first time something like this has happened. it’s a pro app and we are below the row limit.

I have realized the entire issue starts after a certain row which is duplicated in Glide. but not in the Google Sheets. issue highly could be related

Even a glide template column of the RowID column doesn’t show the Row ID . any advice on what we can try is highly appreciated.

@Darren_Murphy sorry to disturb.
any advice from your experience why this could happen?

why would a template column of the RowIDs column not show a RowID after a certain row.

check this also :man_facepalming:

RowID is empty for all rows below that row :man_facepalming:

I think the best advice that I can give is to log a support ticket with Glide.

1 Like

In rare occasions, the Row ID column somehow gets converted to a text column…usually after duplicating a sheet or copying an app. In your table, do you have the option to add a new Row ID column?


Have you refreshed you dev environment (literally) - sometimes the local database and dev get “out of sync” and it takes a physical reload of the actual Glide Builder WHILE in the data editor to refresh the cached data.

That has happened (many times and it is frightening) with me before (but never with ROWID)

Good luck!

No I don’t have the option to add a new Row ID column.

I haven’t duplicated any sheets or copied the app. This is a live app we process over 100 orders per day on the app and have never seen such an issue happen.

I think in ALL occasions, Row ID column gets converted into a text column or at least in my apps that i checked.

Can you double check within your apps, double click a Row ID column and it should show as a Text Column.

Glide recognizes my Row ID column type & value but for some reason at one point this breaks.

There are multiple users using the app. Issue happening with everyone. With the broken/empty Row IDs, any edits updates are lost. While the previous rows everything works fine. whats the best way to refresh the environment?

any idea what happens if I manually insert Row IDs… copy them from the Glide Data Editor Row ID Column and place it in the Google Sheet Row ID column?

I know it’s not recommended, but I also know that I’ve done it in the past, and the sky didn’t fall down :wink:

1 Like

Not sure but probably bad/confusing things. I did this accidentally (using Unique ID) and when Glide needed a ROW-ID for processing it created a ROW-ID A so I had a ROW-ID (manual) and ROW-ID A (Glide) and then I tried to delete ROW-ID which caused weird naming issues.

It still worked (as I recall) but it was very confusing. Not recommended obviously

its confusing. Any updates done on the app now are no longer synched with the data editor. so even though you see them on your device. they are not saved in the google sheets. even if the update is done on old rows with Row ID values.

It doesn’t work…
I have copied the Row ID column in the Glide Data Editor and placed it in Google Sheets.

Relations work better. but any data changes i do on a row are not synced with the google sheet anymore.

I’m guessing edit this row… is not finding the correct row id

My recommendation is to delete the RowID column and readd a new one…obviously, that means any relations you’ve built in other sheets will need to be updated as well.

I had this in mind. I have tens of columns probably over 100 that use a Row ID value. its gonna cause too much issues. considering the app is dealing with daily live orders its a huge risk i was hoping not to take

It sounds to me like you have a larger issue that needs to be dealt with by support. Have you logged a ticket?

The last thing in the world I would have expected was an issue with Glide Row ID. I recall Row ID being a very well supported feature and everyone advised to use Row IDs. :frowning:

Yes i have. I received an email later on asking me for a support link which I had already attached to the ticket. Hope they get back to me on this soon

Luckily, before testing it on the Orders Table, I tried this for a minor table that is easy to fix and got this MSG !!
Glide could not set the column Row ID and will have to close the app