Relations not showing up

I haven’t been done any work on my app in a few weeks and now, when I try to troubleshoot my relations, these dashes are what appears:

I’m trying to build new relations in other parts but I can’t because I don’t know if they’re actually relating - all I’m getting are these dashes. Is anyone else experiencing this?

Triple check that the two items you are relating are the same i.e. if you are relating to emails, make sure they are exactly the same. If there’s something different this will happen

Hey Pablo - thank you for your quick response. It’s not just that sheet that has the issue:

It’s just text, no pictures or anything fancy

I had this very same issue last week, and it ended up being an email that had two capital letters, and so it wasn’t the same as the other email I was trying to relate it to. It looked like it was trying to relate it but didn’t show the data, even the lookups worked, like in your case. But I recommend going through the data again, that’s the only thing I can think of.

I’ll see what I can see but, like I said, I haven’t worked on this thing in about 6 weeks and nothing has changed on the backend. Additionally, the relations are still functional - I just can’t see them in the Data Editor

Thanks again!

1 Like

If I can be of any further help you can write me a PM

1 Like

Do you happen to have empty columns in the row you are relating to?

I do - I created a “Title Text” column that I intentionally leave blank so if there’s a heading or title I want to have disappear, I choose that. I was able to create a new relation after I posted this message, and the data appears in the column, but still not in any of the other sheets that I have from before

I suspect that the relation is showing that empty value column to you, but still, the relation is there.

Glide is showing that the system has found rows that match your conditions, and then what you see is a random column from the row that you’re relating to. It happens to be an empty one in this case I think.

1 Like

Hey Thinh - thanks for your response. I deleted the Title Text column from the sheet in question and the dashes are still there :man_shrugging: Not a very big deal, I suppose, but it definitely makes it harder so see if I’m relating stuff correctly

If there is a particular column that you really want to see to verify if the relation is set up correctly, then just add a lookup column against the relation and select the column you want to view.

1 Like

Thanks Jeff - I just found it to be odd because they originally showed up but now they aren’t. The relation still exists and doesn’t appear to be broken


Yeah, personally I don’t pay much attention to which column value a relation shows as it’s just an indication of whether or not matching rows were found.