Relation not being found

Hi! I have several relation columns (see image below) that are linking the “Format” columns with the matching record in this same table. As you can see, it finds 1, 2, 3, and 5. But it does not find #4 even though there is a match. It just doesn’t display. I’ve setup all the relations similarly so I’m confused as to why it’s not working. Any thoughts? Thanks!

Can you show your settings for that relation?

Sure. Here are both the #4 and #5 relation columns.


Just trying to understand. You mentioned that you are using the ‘Format’ column values for your relation, but I don’t see them being used in your relation.

That aside, is there any chance that the value in your ‘Value’ column or the value in your ‘Total Profit’ column has has an underlying unformatted number with decimals beyond 2 decimal places?

Is using a calculated value the best way to build a relation? Hard to say without knowing the purpose of the relation.

Sorry, I’m using the value column as the relation, not the format. :crazy_face:

The value doesn’t appear to have any decimals. What I’d like to do is find the Ticker symbol that matches the list value. So I’ve sorted all the totals from largest to smallest. Then I’m trying to make a “top 5” list that shows the ticker symbol as well as the profit total. But for some reason #4 is the only one that doesn’t show even though the value is retrieved. So on the UI it would look like this:


Where are your Single Value ‘Value’ columns getting their value from? Also, which column is the related Rollup column summing it’s value from?

I tried to make a video to show how I set it up:

OK, I have a theory. I think it has something to do with row 4 being under a different row owner. Your Single Value columns are looking for a specific row position. Because row 4 belongs to a different user, it might not be seeing any value. Glide can be a little weird when Row Owners are applied and you are viewing it in the builder. It will show you all of the data for all users, and sometimes that causes some weirdness with computed values. In reality, those unowned rows would not be downloaded to a user device. Can you try with the published version and see if that makes a difference? I’m guessing that it may work correctly with the published version because those unowned rows would not exist in the published version.

I do have the app on my phone and that 4th ticker still doesn’t show up. It looks just like the builder view :worried:

Is this production data, or just testing? Would you be willing to try either deleting row 4, or better yet, change the email to your email temporarily?

Hello! So it’s production data (live app), but this tab is visible only to me currently. So after changing row 4 email to mine, or even deleting that row, the issue is still there (no ticker symbol).

So if I change the value from “3” (to find the 4th value in the Duplicates array column) to “5” (to find the 6th value), then the ticker symbol shows up. So there’s something going on with that’s 4th value. Just not sure what it is…

So if I pull the third position (864; 4th value in array) from the duplicates, the ticker doesn’t show. But if I choose the first position in the lookup column (which is the same 864 value), then the ticker does show.

Check another thing for me. I’ve made this mistake before. When you are pulling a single value from an array, sometimes you can see the same column in two places in the ‘From’ setting of the Single Value. One is the single array column in the same row, which should be shown at the top of the list when you click on the ‘From’ dropdown. The other place you see it is in the table>column option in the dropdown, which searches the array of values from the column in all rows. I’m not sure if that’s the case here, or maybe further up the line. That’s why I suspected that maybe your the unowned row was somehow the culprit, but from what you say, that is not the case.

Other than that, I’m running out of ideas. What you’ve shown seems correct, unless there is an issue with the Duplicates plugin. I haven’t used a lot of plugins yet, so I’m not very experienced with them.

Would you be willing to make a duplicate of your app (duplicating data as well, so you don’t interfere with your existing app), strip out any private data that you don’t want to share, and then share the published url of the copyable version so one of us could take a deeper look? I think at this point I would have to get my hands in there and play around to see what’s going on.

1 Like

There were two other places to choose in the “From” dropdown, but they just produced a series of numbers, and not a single value.

So I copied the app here for troubleshooting:

Thanks again for your willingness to help out us newbies!

Can you enable copying?

Oh yeah, sorry about that. I enabled copying…

I’ve been looking at this for awhile. For the life of me I can’t see where it falls apart. I will admit, you do have a very elaborate setup. The only thing I keep looking for is a floating point decimal that’s hiding somewhere, but I’m not coming up with anything yet. My other thought is that the plugins are failing or returning a bad value somewhere, but I’m not seeing it. In theory, the relation should find the very first row in the table since it has the matching LCID value.

I’ll keep looking, but I’m not having any luck so far. This might be something that will have to be submitted to glide. It’s possible that it’s some kind of internal issue or error that I’m just not seeing. If that doesn’t work, then maybe we need to come up with a simpler approach. I don’t know yet. Just wanted to give you an update.

1 Like

Ok, thank you so much.

When you say “elaborate” is that a good or a bad thing? :woozy_face:

1 Like

Hehe, neither. I’m just saying that it’s not a simple app. You’ve obviously put a lot of work into it and there’s a lot of steps and columns to trace through. :wink:

1 Like