Relation Column is not accepted

Dear All,

I am creating app for imaging/microscopy facility -
I have added the Relation Column (Microscopes Relations) to the tab Rooms, but in layout, it is not accepted.

Please help.

Best regards,

I’m going to need more information. What exactly are you trying to do? Do you have any screenshots from the data tab or the components you are using on the Rooms tab? What exactly do you mean by the relation not being accepted?

Dear Jeff,

It looks very strange. I have created relation column, but in layout it says there is no relation column. I have tried different combinations: tried to create in microscopes tab relation column matching rooms and opposite - in data tabs room relation column microscopes. In both cases there is message: “No relation column”.
I tried to repeat the same procedure with template creating additional relation column based on staff template. At the beginning I had the same problem, but later the system was able to recognise the new relation column.

No ideas how to fix this,

Best regards,

Are you using a single or multiple relation? Which component are you trying to use?

You cannot use match multiple relations with the Relation component — it only works with Single relations.

(Sorry, we know this is confusing and will fix it.)


Dear David,

Thank you very much for your response.

Best regards,

Hi @david,

Just came across the same issue and came in here to fix it, found the post and now understand the issue.

Wondering if it had been fixed?


It’s not necessarily a problem that needs to be fixed, as opposed to just a misunderstanding of how it works. A Relation Component only works with a single relation. The Inline List and List Relation Component only work with multiple relations.

1 Like

No way!

I have almost 4 weeks try making to work a Relation component and now I got the answer!!

Thanks @Jeff_Hager

Ha! Well, you’ll never forget now. :wink:

OK cool, thanks Jeff! I’ll take another look - working through the vids online and trying to get my head around things. Still very much learning!

1 Like

Hi, I am pretty good with relations now, however for the first time, I am having an issue with a relation component that is not working. i have my single relation column displayed in my data editor with data in it. However, when I am trying to pull the informations, it’s says there is no relation column. Usually, when there is a relation column, it gets it straight away. I don’t get why it is not working this time.
In advance, thank you for your help…

Can we have some screenshots, and have you tried refreshing the builder?

1 Like

it is working now. I think it took longer that usual to update.
However, many thanks for your prompt reply and support. Appreciate it.
I am new to glide.
Sorry for bothering you.
Cheers and many thanks again.

1 Like

No worries about asking questions, always feel free to post in the community, we’ll try to help!