Relation component is not showed

Hi, it’s my first post here so i apologize in advance for any mistake.
I’m trying to make a quite complicated app. What I want now is to search from the “Scan User” tab informations (that are stored in the “Users sheet”) about the user that i’ve written the code. To do that I thought to use a relation column, and it worked in the data editor, but when I tried to add a relation component in the layout of the app… it didn’t show anything.

It seems to be configured well but I can’t see anything.
If you have suggestion please let me know. Thank you!

First of all, a Relation component will only work for a single relation, so it will only be able to display one matching result. If you have a multiple relation, then that only works with a List Relation component or the Inline List component.

It depends on how you are trying to display the information. Personally, I never use the Relation or List Relation components. I get a lot more flexibility out of an Inline List, bit that’s just my preference.

But for your problem:
Single Relation → Relation Component
Multiple Relation → List Relation or Inline List components.


Thank you for your reply. I’ve set up single relations, and it works fine in the data editor but the component is invisible (?)… Nothing shows up although I can select the column for the relation component.
Any idea?

Are you sure that your screen isn’t filtered or showing a different row that you are expecting? Maybe you are viewing a row that has an empty relation? Can you share some screenshots of your relation column settings, then value you see in your relation column, and what you see when you set up the relation component?

It is possible too that you need to create a lookup column in the table where you created the relation. Then use that lookup column in a component.
here’s the folder with the screenshot… sorry but it says me i can’t embed photos

This is what I see… The relation in the data sheet seems ok, and the LookUp column too.
Hope you can help me in solving this

Looks like everything is set up correctly. Do you have any filters or visibility conditions set on the relation component?

Also check if you have any columns with Row Owners set in the table you are relating to. That could more likely be the problem. You could be relating to data that is under row ownership, but the user you are previewing as doesn’t have access to that data.


Thank you, you’re the best. The problem was with row owners!
Have a nice day!

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.