Problems with onboarding (Glide Apps)

Hi Gliders,
I am busy with my new app and I have created a “Welcome” screen.
I just installed the Glide app on my phone, to see how things work, but it is not going the way I was hoping.
I cleaned all the test users and other info, so I started blank.
When I open the “app” on my phone, I need to login.
So far everything is good.
I choose to login with my Google Account
I get the “Welcome” screen and I can fill in the needed things.
I had set the “Welcome” screen so that once everything is filled in and the user was approved, this screen will not be shown again.
So far things are still good.
Then I use another phone, I install the app, and open it.
Again I get the login screen (that’s good) and I choose again to login with a different Google Account.
When I reach the “Welcome” screen, I can see all the details from the first user.
This is also the first user in the user sheet.
I know something goes wrong, but I cannot figure it out completely.
For some reason, it is not creating a new row, but I have no idea how to do this.
I cannot see anything to create an action or new action.
Does anyone have any idea how I can fix this?
This is my first app that will be used also by other users. The other app I have made is only used by myself.
So if you could be as clear as possible, that would be nice.
I am still learning :slight_smile:
Thanks in advance for all your help and tips.

  • First thing, check and make sure you have User Profiles properly configured. As long as you do, then a new row should be automatically created for each new user.
  • Second thing, check if you have Row Owners applied in your Users table. If you don’t - and you don’t need it - then you need to apply a filter to the Welcome screen: where email is signed-in user. This will ensure that each user only sees data from their own user profile row.

Hi @Darren_Murphy ,
The first thing I already had checked and it was correct.
The second, I did not do this. I had set row owner and tried it again.
Now I can see an new row was added, but I get an “empty” screen in which I cannot do anything.
I can see the entry field for the user name, and other details, but I am not able to enter anything. Everything is a bit greyed out.
Any idea what I am forgetting?
I also have one tab where I can see all users.
But when I set Row Owner, then my list is empty.
Setting the row owner, is giving me more other problems.

If you want to see all users in a list, then you don’t want to use Row Owners because the app will not even download the data for those other users. So, in that case, I would disable row owners and instead set a filter on your welcome screen.

Now, I know in the past, there has been issues with new rows not generating immediately in the user profile table. I don’t know if that is still an issue or not. I would double check again to make sure that you have user profiles configured correctly. If you can, show a screenshot of that configuration so we can ensure that it is set up correctly. Like @Darren_Murphy said, a row should generate automatically when a user signs in for the first time. Then your filter will find that row and the entry components won’t be grayed out. They are grayed out whenever the screen is not attached to a matching row.


Hi @Jeff_Hager ,
I had removed the row owner, because it was causing more problems for me.
I did a quick test and saw that a new row had been added to the user sheet.
But the data on screen, is from the first row in the user sheet.
I had to go out due to some appointment, so I am not able to make screenshots.
I think it will be tomorrow before I can place them here.

You need to now apply a filter to your welcome screen where email is signed in user.

1 Like

I had done that
But when a new user signs in, a new row is added, but I see the data from the first user in the welcome screen entry fields.
And for some strange reason, the text entry for the name is not showing.
Only last name and other details.
Tomorrow I will make screenshots.

If you are still seeing the first row of the table, and it’s not the row that belongs to the user that signed in, then you either do not have a filter on the screen, it is configured incorrectly. It should be Email is Signed in User.

If an entry component is not showing, then you may have a visibility condition in that component.

Make sure you didn’t mix up filters for the entire screen and visibility for a specific component.


Hi @Jeff_Hager,

You were partly right.
One of my filters was wrong.
That’s why I was missing the First Name text entry.
I checked if the user is the signed-in user, but I think that is where it goes wrong.
I think it is because I am on the free plan.
The email address that is recorded in the row, is a fake email address, so it will never match the email of the signed-in user.
Because I keep on seeing the details of the first row in the user sheet.
Is there maybe a way around it?
I tried it with the name field, but there you cannot check if it is the signed-in user.

First of all, we’re talking about filters and visibility, which are two different things, so it’s important to know which is which and what each one does. Second, Glide knows who that anonymous email belongs to, so it will work. Just because it looks fake, doesn’t mean it’s not deeply attached to the identity of the signed in user. It doesn’t matter if you are on a free plan or a paid plan.

I still think you are mixing up component visibility and screen filtering. Can you show a screenshot of the filter set for the screen? Also, you should not have any visibility conditions set on any individual components , so I want to see a screenshot of your first name component option settings.


Hi @Jeff_Hager ,
I checked everything again and made some screenshots.
I hope they are clear
This is the visibility settings

This is when I log in with my first Google Account. The data in the entry fields are okay and correct.

When I log in on my other phone with a different Google Account, I get this;

In the user sheet, I can see the new row and you can see that the name is empty, but for some reason, it is taking the data from the first row.

I hope the screenshots are okay.
If you want to see something else, then please let me know.
Many thanks for all your time and effort.

The problem is in your first screen shot.
You are using tab visibility where you should be using filtering.
So all you need to do is remove the visibility setting, and apply a filter - where email is signed in user.


Visibility controls IF something is visible. Filters control WHAT data is visible.


Hi @Darren_Murphy ,
Wow, that was it.
Visibility and Filtering. Something I really need to keep an eye on.
It is (for me as a beginner) a little bit tricky.
Things I really do not need to mix up :slight_smile:
Thanks for your help and time