Open Link opens a slightly different link

Hi, I’ve created a WhatsApp link generator with Glide.

Works great until I realized that the URLs look different.

If you see the image below, the first link on top is missing ‘%0A%0A’ for a space and line break.

The URL below is from Google Sheets, which shows with the ‘%0A%0A’ for space and line break.

Any idea how to fix this?

Does it make any difference in the displaying screen? I think it’s just related to URL encoding in the browser.

Oh it does make a lot of difference.

The top link sends a Whatsapp message in One line, but the second URL sends the message With Line breaks. :slight_smile:

What you want is line breaks right? So from my understanding you have the right configuration in Sheets but when you use an open link action on that same link it opens the wrong link?


Have you tried using the Construct URL column to do that instead of the Sheet?

1 Like

try to use \n for breaks and %20 for spaces in template column

tried, didn’t work and it adds a ‘/’ to the end.

this isn’t necessary when opening from Sheet, the %20 automatically appears in the URL.