"open link" on submit form is not working well


When I confirm to submit a new form, I have an URL leading to whatsapp.

On my desktop it works normaly, but when I do access it through my iphone, it doesn’t works, and not open my whatsapp app.

What am I doing wrong?

PS: I have some other buttons leading to whatsapp and all them works well on both devices.

So it does not open any link at all?

I think the case here is the link might not be created in time for the action to work. I have found actions using on submit to fail intermittently when you rely on a value to be created after the form is submitted.

1 Like

But it works well on desktop. It only bugs on my iphone. :frowning:

I just used the same link as a normal button, and it opens normaly, even on my iphone!

It only does not works if I try to use this link on “open link”, when I submitting a new form.

I have tried many links, like www.facebook.com for example, and it does not works, when submitting forms via my iphone. Works normaly on my desktop, but not on iphone.

I agree with what @ThinhDinh said. I am very hesitant to use any On Submit actions if they rely on the submitted data in some way. I’ve seen way to many reports of On Submit not always working correctly or working sporadically. Keep in mind that desktops have a lot more processing power and can probably process that new row much quicker than a phone can process it. I believe those On Submit actions are running synchronously, so if the row has not been completely created by the time the On Submit runs, then things may not work. I just avoid On Submit at all costs, unless I’m doing something simple like showing a notification.

So, I’ll ask this. Even when you try other links, is that link coming from the newly created row, or are you just hardcoding it into the Open Link action? If it’s just a hardcoded link, then maybe it’s not the problem I described above. Maybe it’s something with the form closing before the Open Link can execute. Maybe it’s browser or OS specific. Is your desktop a Mac, or Windows? Are you comparing Chrome to Safari?

Regardless, I’ve just never trusted On Submit.

I used chrome/windows on both tests. At first atempt I’ve tried to open a link coming from the newly created row, but, after, just for testing, I tried to put “www.facebook.com” directly on the “open link”, not on the row, and it keeps malfunctioning.

Maybe you’re right saying that

I just createad a brand new button using “Action Text” to press right after submitting the form. It’s not the ideal, but is working fine.

1 Like

I agree, It’s not ideal. I wish I had better answer for you, but it’s been a behavior that’s been around for quite a while, so I’m not sure if it’s something that Glide can fix it not. Many of us have asked for a ‘delay’ or ‘wait’ function with the hopes that it would take care of some of these weird issues, but no luck there.


This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.