Not syncing

My app’s URL:

My free app has been working fine. I recently updated a row in my spreadsheet (yesterday); more than 12 hours later, it has not synched.

I am getting a little close to my free quotas, but I haven’t reached them:
Rows 434 / 500
Sheet Edits 342 / 1,000

I have tried things like editing the google sheet again, and editing the data sheet for Glide. Nothing has caused it to sync.

Any help would be appreciated!

You have the yellow triangle. That means there is a sync issue. That usually happens when you alter column headings in a sheet that are still being used by the app. Have you gone through resolved all of the issues that are preventing it from syncing? (Click on the reload button to see what the issues are)

Thank you for your response. I do not think the yellow triangle is a data issue (I can’t find a data issue). The issue is with my colors, which I accept, because I my colors are very specific, and I don’t see the issue.

My bad. That always gets me. What happens when you click on the reload button. Looks like it may be partially hidden underneath an overly, so you might have to adjust your screen zoom first.

1 Like

I am on the Free tier, so my understanding is that the reload button is disabled.

`In free apps, Glide refreshes your app data from the spreadsheet whenever the spreadsheet is manually edited. Therefore, if you use formulas that produce different values at different times without requiring manual edits, such as NOW, IMPORTRANGE, or GOOGLEFINANCE, your app data will not stay up-to-date.`

(I don’t think it is relavent, but I did just add an IMPORTRANGE on another sheet. )

I have tried making numerous manual edits to my google sheet, and to the Glide Data sheet, just to make “something” happen. Nothing has synched.

For the record, my app is fairly complex, and has otherwise been working find for about a a week now.

All that means is that glide will only check for new data if something changes in the app. Otherwise with pro, you can turn on an automatic check for new data. You can click on the reload button all you want. It’s not a pro only feature. It’s a development feature so you can be sure you have the latest data when developing the app.

Thanks so much for your help. My issue is resolved.

I thought I did not have the sync option available to me. :expressionless: In fact, it was not showing on my smaller laptop screen. F11 to maximize the browser was the trick.

I had removed a sheet I wasn’t using, and that was causing the issue. When I ran the sync, I was able to resolve the issue.

1 Like

Yep, looking closer at your screenshots, I can in fact see the tip of the yellow warning triangle barely poking through.

Glad you got it working.