New users are put in the bottom of the users sheet even though there's no array formulas used

I have added a few sheets to my Glide app Google sheet and since then, all of my new Users are put on the bottom on the sheet. I don’t understand why as I made sure to include no array formula on the Users sheet directly, however, I do use the data on the Users sheet in other sheets that use them.
This used to work fine until I added new sheets.

I rely heavily on Integromat to automate actions on my app via Google Sheet, and when the users are put in the bottom of the sheet, a lot of those Integromat flows do not work.

Does anyone has a idea of what could be causing this issue ?

PS : Here is a sample of the “Users” sheet of my app (This one only includes fake user data) My real “Users” sheet has around 140 users and the entire Google sheet has around 30 differents sheets.

1 Like

I don’t see anything that would cause it to put data on the last row, but I do wonder how you are setting the formula for your paying user column without using an arrayformula. What happens if you delete all of the empty rows?

Currently, I don’t even use this column,I should remove it, but the formula used in it is =IF(C2=“speakingagency”, “yes”,“no”), it’s not an array formula.

When I delete the empty rows, when a new user is added, it’s put automatically in row 1009, even though there’s nothing in the rows above…

I have had the same thing happen & spent forever trying to figure out why the data editor showed users signed in but my sheet was blank! I deleted the tab & have reconfigured it & so far it hasn’t happened again. Not a solution I know.

So how do you populate the new row with the formula if you don’t use an array in this case?

When you say you deleted the empty rows, I want to make sure you didn’t just clear them. If you only have 50 user records, there should only be 51 total row visible in the sheet (including header). The only weird issue I have seen before is when someone was filling the sheet with a UNIQUE formula I believe. Somehow the Google sheets formula would automatically add 500 rows of it needed more room than was available. They also had checkbox validation set for one of the columns. I see you have a checkbox in your sample sheet, but it doesn’t look like it carries down through the entire column, so I wouldn’t think that would be a problem. Is there any chance you have data or a formula somewhere around row 1000 or after that may not be visible, but enough for glide/Google to see that it needs to add records after it?

Deleting all empty rows should take care of this unless a new entry recreates the 1000 empty rows.

1 Like

Thanks, it worked ! Creating a new entry works as intended :slight_smile:

1 Like

the row wasn’t populated, it was only something I tried when I created the first users.

1 Like