My app icon doesn't show up when adding to home screen

My app’s URL: (if not try

I believe it is a bug since I have already done that same task for another app I have created and it worked perfectly.
When I try to add my app on the home screen of my IPhone, the icon displayed is a screenshot of the app page instead of my app icon.


Look at the gif above.

How can I fix that?
Thanks :slight_smile:

Sometimes it take some time (a minute?) if the app is too heavy.
If it doesn’t work, try resetting your phone.

1 Like

Same issue here, nothings work (clearing cache, incognite, etc) I wrote to support, the dev team is looking at, hope can find the solution soon.

Like @eltintero mentioned, I’ve found that the icon eventually loads if you wait a minute or so after pressing “add to home screen” but before hitting “add”.

1 Like

Yea, it happened to me with other apps, no with this one, if you add an emoji it show the emoji, but no the image

what file format is your image? PNG works best. Also make sure the filename is simple…no punctuation and keep it short.

Yep, PNG with name “favicon”, nothing works my friend, I thinks is problem with Firebase, look the attachment.

You on a mac? What happens if you open it in Preview…do an export to PNG (redundant…I know) and then reupload to Glide?

no work :pensive: it’s frustrating

send me the image?

1 Like

Im getting the same issue too.

I have the same issue on the home screen app icon. It worked fine on the first one then the second app - basically duplication of the first, it doesn’t work. It shows the icon then overlays with a screenshot.

That’s exactly the same thing that happens for me. Maybe there is a thing related to duplicate apps?

This is a bug. I tried with apps I’ve already created, too. Not pulling the uploaded icon…only a screenshot or emjoi.

Same with mine - I assumed that it was me !

It’s fixed now, thanks Glide team

Perfect on my side. Thanks

Yay! thanks Glide team!