Map Pins display at incorrect locations

I am new to glide. I am currently building a lean version of my app in the free version. I noticed after about 5 days my location pins are not correct including some showing locations in Europe. I double-checked the address info, deleted that info, and added it back to no avail. I don’t want to delete the entire column unless the cells are corrupted. Has anybody dealt with this issue? Thanks in advance

Can you give us one of the locations that is incorrect?

Sure! 133 S. Barton St. Arlington, VA 22204. It was correct and displaying fine for the first two days

I also changed the format for the data from the entire address in one cell to Street, City, State, Zipcode

So you split those addresses into multiple columns after it was working for a couple of days with a single column? Which of those individual columns are you using for the address setting in the map, and which column is it currently set to? You will get random results if your map is only pointing to a portion of an address instead of the entire address.

@JC23 have a look here where it is described that you should work with coordinates instead of addresses

2 Likes

Jeff yes I did change all of them but only a few are now showing(pins) incorrectly. I changed those back to see if that would help to no avail. Also, the place that they show currently doesn’t seem to correlate to anything/map coordinates/street info at that particular location

But what what is the address setting on the map settings? I’m trying to understand if you are pointing it to a portion of the address or the entire address.

Okay great, I’ll have a look, thanks.

I get precisely the same location in Glide and Google Maps for 133 S. Barton St. Arlington, VA 22204:

1 Like

So originally I was pointing to the entire address that I had formatted in one cell. After I changed it to the separated partial addresses some displayed incorrectly. When I changed the incorrect ones back to the single-cell they did not self-correct. So I did not look at the settings. I will check the settings to see if that needs correction. then re-do the addresses to a single cell. It was suggested that we add coordinates then point the addresses to coordinates.

Coordinates will always be more accurate, but an address needs to be located in one column and that map address setting needs to point to that column. As an alternative, you can always keep your address columns separated, and then join them together with a template column to have a single column to use for the map.

Okay, I’ll reset everything then add the address back to a single cell, and then point them to the coordinates as well.

I don’t think you need to use coordinates. For me, it works for 133 S. Barton St. Arlington, VA 22204 – I think you just need to double-check your Address property.

1 Like

Jeff, I should have left it at a single column, it felt junky so I changed it. so clients will submit the address info obviously without coordinates. What can you suggest we do to add the coordinates to the entry without singularly looking up the coordinates and manually doing cut and paste?

Just use the template column to join the address parts into a full address, then use that as Address for the map. That way users can enter as parts, and you can still use a complete address with the map.

3 Likes

I still would like to know what your address setting/property is set to in the map settings.

David, I am going back to the single-cell address and double checking my settings. Everyone has been very helpful! This is my first time posting and this has been one of the better community experiences I’ve had, Thx.

3 Likes

You got @Jeff_Hager, @Robert_Petitto, and me on your first post?! Lucky! :wink: :laughing:

3 Likes

Do you consider the template column to be a better way to go over the single-cell addresses?