Problems with displaying addresses on the map

Greetings to the community.
I have a problem that I can’t figure out how to overcome so I’m asking for help from both the experts and the Glide developers.
I have also searched for a solution, but have not found any answers.
I have developed an application with Glide with the intention of showing new and interesting places to all users who will use it. All places are in Italy. Now I ask why, if I display them on the map, some of these places are in other countries.
I enter all the address data, in a text field, with the address complete with the postcode. Is there a more suitable system (e.g. latitude and longitude)? Honestly, I have also tried with the latter data taken from the google maps URL, but the result does not change.
Any suggestions?
Thanks as always to those who wish to answer.

You should be safe using geocoordinates. Mapbox does have trouble geocoding addresses sometimes, so if you directly give it coordinates it should work. Can you share a sample of the coordinates you are using? Also, can you double check that the address setting for maps is pointing to the address or coordinates column?

Surely the map column points to the address of the place. The only thing is that I use an address instead of coordinates.
However, the coordinates I use have this format:

43.404858194063756, 11.136246813274921

Are those coordinates ones that aren’t working correctly? I threw them into my test app. The column name is ‘Barcode’ so you can ignore that, but it is where I placed the coordinates and pointed the address setting to. Is the location shown correct, or should it be somewhere else?

image

This is correct.
Not this way:
Montella Bioparco, Montella, AV

This is what I get when I add Montella on another row. Seems like it’s correct city when I zoom in. If you have an address column and a coordinates column, then I would point the address setting to the coordinates column since you should have better luck as far as accuracy.

I would consider this for a complete address, but coordinates are always safer.
83048 Montella, Province of Avellino, Italy
or
83048 Montella AV

Using those recommended addresses and also coordinates seems to all give me different results from google, so I’m not entirely sure which one to believe. Is the google result that I shared correct?

This is correct. But I need to understand why often, especially when there are several addresses, the system does not work as it should!
Probably for places where there are no precise indications, it would be better to use geographical coordinates.

Like I said, Mapbox, just isn’t as good as google when interpreting addresses. Behind the scenes, it still needs to geocode the address to coordinates so it can display the pin on the map. It can be hit or miss sometimes as far as how correct the location is.

1 Like

Thank you Jeff for your reply.
I’ve been playing around with the map parameters and I can tell you that thanks to your advice, I succeeded in what I wanted.
I either have to enter the location data, the postcode and the province, or, for locations in a park for example, copy the latitude and longitude directly from the placeholder in Google Maps (more precise).
In your opinion, but the answer is addressed to the whole group, is there a possibility to store the zoom of the map and its centring? :blush:

2 Likes

The map list view doesn’t have any way to set the zoom. It will attempt to set the map extent to include all pins within the view.

If you are using the map component on a detail screen, then you do have the option for Near, Medium, and Far zoom levels, but that’s only for a single location.

In either case, I don’t think you can set and save the centering and zoom level beyond what it does now. The idea is for the user to pan and zoom around the map as needed. If you were willing to have a static view of the map, you could screenshot it with the zoom and centering how you want and then save it as an image and display the image, but there wouldn’t really be a way to interact with it then.

1 Like