Map isn't showing in Pages

Hi Gliders,

What’s the status of this issue with the map not showing in Glide pages?

I just created a new project to get more familiar with “pages” and created a map from this address template: “Street, zip code, city, state, country”

The map isn’t showing.

Tested with: Android; chrome & Firefox and iPhone chrome & safari

Regards, Ronald


Make sure the data exists! If it’s missing bindings or has empty data, it might not show.

Hi David,

Thank you for your response.
Yes, the data exist. Of course!

If i load one of the new Glide templates with a map the same thing happens; no map. In this case your “delivery” template.

Please look it to this.

Regards, Ronald

I am using maps on a “page” without issues. Not using one of the templates, I have an address column in a data table and use the map component on a screen.

Hi Kabookie,

Thank you for your reply and answer.
I don’t understand; i tested with exactly the same data (the same Glide table) in a newly created “classic” app and now the map works in the “classic” app as expected.

It still doesn’t work in the “pages” app (with the same date and shared Glide table).

Regards, Ronald

Can someone from support pick this up, please?

Regards, Ronald

Support does not open tickets from this forum, you must use the help link in glide. If you share some screenshots, the forum can assist, but you need to be much more specific with your issue.

1 Like

Hi Kabookie and thank you again for your answer.
The support link you mentions is not available for non business accounts.

I think the problem is in my account…

When i copy the Glide template “delivery” (witch has a map) into my account the map doesn’t display also. So, the problem is no in my data or settings i think…

I build many “classic” apps and the map always work. And then; when i test with a newly “classic” app with the same “shared” Glide table and the same data, the map works in “classic” but not in “pages”. Strange…

But… thank you again. I will ask support for some help in the matter.

Regards, Ronald

1 Like

I copied the template into a free account test folder and the map shows up fine.
Are you using Chrome or another browser? Are you using the most current version of Chrome?
Are you trying to copy it into an original “my apps” folder? That could also pose an issue.
Not sure what else it could be.

I think there’s a problem recently with maps on Pages with Chrome. Can you try it on another browser?

Hi Thing Ding and thank you for your question!

Yes, I have. I tested with Chrome, Safari and with Firefox. All the latest versions on a Android phone, a iPhone, a MacBook and on a Chromebook.

All the same result. In “classic” it works; in “pages” only a gray square… No map.


Bummer. It didn’t work on one of my Pages on Chrome. I switched to Arc Browser, which also uses Chromium, and it works on there. Now I don’t know what the real reason is.

When you go to the template page, do you see the map or is it also a grey square?

Hi Kathy and thank you again.

I don’t have a “my apps” folders but I see what you mean. Tomorrow i’ll al so test with another account. Good thinking! :grinning:


When I use the copied template app “delivery” I al so see only a grey square, no map.

Kathy suggested to create a new free (test) account and test with that account. That make sense in my opinion and I’ll try that tomorrow.

Regards, Ronald