Legacy free app not updating when I edit the spreadsheet

Team ID:
https://go.glideapps.com/o/8RxNXCFSqHdV54ihJNAe

App ID:
https://go.glideapps.com/app/YJAnx0gybwcQzkAEp4HG/layout

Description
I have an app that was working under the legacy free plan. The app is backed by a google sheet. This app has been working for 2 years. Now (since last thrusday or so) when I make a a change in the spreadsheet it does not push the data out. If I do a sync from the builder it works. All changes made thru the app get sent to spreadsheet and to all other apps.

Work around - I rewrote the app to use the new free plan. For me there is no urgency

Following is usage report

How to replicate

  • List the steps, in detail, for recreating the issue.

Hey @Gary_Biagioni,

Glad to hear you got around it by moving to our new Free plan.

For posterity: We took a peek at your old app. It looks like Google Drive is throwing a quota limit error for your workspace.

I’ll move this thread to Ask for Help since it’s app-specific.

Thanks for looking into this. Not sure which what limit google Drive is meeting. Sure is not a storage limit as I am using 382MB of 15GB.

I have another app doing the same thing. Will just convert it as well.

Can someone clarify the workaround, please? I need to switch to the new plan? What do you mean when you say you “rewrote the app to use the new free plan”? If I have two apps, will one get deleted or be disabled? Thanks!

What happened is I had an app running on the legacy free plan and changes made to the spreadsheet quit being automatically pushed out to the Glide data tables. However, changes made with the app went to the spreadsheet. I still do not know why this stopped working.

I needed this app to be running for free. The new free plan does not allow the use of google sheets. This app was written using the older builder tool not the new pages builder. My choices were to add on some user interface for updating the information we were doing by hand in the spreadsheet (with the possibility that the calculations based data would not update) or upgrade to the new pages. Fortunately, I could rewrite this app to not require the calculations in the spreadsheet, although I did lose some functionality. So I felt the best plan was to rewrite the app using the new pages development tool. Not really a work around but it solved the problem.

As an aside…
I thought I would be able to just disconnect the spreadsheet from the Glide tables by just deleting the spreadsheet, which I tried but it still showed up in the data section of the development builder. This concerned me so I decided to also rebuild the Glide table structures. So not only did I have to rebuild the app but I had to redo the Glide table structure. I could however import the data from the spreadsheet that I needed to keep. By the way, It took about 1/3 time to rebuild the app using new pages builder.

Ah ok. That won’t work for me. I have data that updates in the spreadsheet that can’t be incorporated into Glide tables. Can any staff clarify whether data from spreadsheets is still supposed to sync to Glide automatically? And if so, can someone please assist with the bug?