IOS devices unable to open links from image component

Hello everyone,

Just noticed an issue where ios devices are unable to open links from an image. (android ok)

The links work on the link component (for ios), its just for image components where the action is open link.

Link to App:

The image component expects the URL to return an image, but your URL appears to be returning HTML. So I think what you are seeing is expected behaviour.

Thanks Darren!

Sorry if it wasn’t clear from the screenshot, the image url is in the white-out box near the top. The action being configured is an open link action when clicking on the image. Or at least thats what I understand the action to mean.


the open link action (from image component) works fine on android devices, only encountered issues with ios.

ah, I see.
Okay, let me test this myself.

Update: @Hans it works for me, tested on IOS.

When you say it doesn’t work, what actually happens when you try?

1 Like

Hmm thats weird, we’ve tested on a couple of devices.

Doesn’t work = literally nothing happens, we still remain in glide, no error message pops up.

Might there be geographical settings from ios end that are affecting this? i.e. location specific policies. We are located in Singapore if that helps.

Possibly, but I’m also in Singapore :slight_smile:
I tested with

for clarity am refering to iphones/ipads when speaking about ios

yep, same. I tested with an iPhone 12 running 15.5

Here is how I configured it:

I published this change and opened the app with my iPhone.
When I tapped on the image, the link opened in a pseudo-browser.
When I clicked on done, I was returned to the app.

Thanks Darren!

Nice to know that there are fellow Gliders in Singapore! :slight_smile: Thank you for the advice and testing this out!

We have some devices running 15.5 too but still not working out for us, unfortunately.

Thank you so much!

Have you tried with:

I removed the www part, I think that was possibly a reason it didn’t resolve correctly, because Telegram links are (not with www).

Thanks Thinh, have tried it out, but unfortunately it doesn’t work on the ios devices still. Not sure why this is the case and interestingly Darren wasn’t able to replicate it with his ios device.

So it does work on other devices? I can’t access that through your app via Chrome on MacOS either.

Thanks for checking Thinh! have also tried with a Mac (safari and chrome) and it doesn’t work as well.

So far only seems to work on android and windows.

I tested this button on MacOS Chrome and MacOS Safari, it all seems to work fine.

Any chance you didn’t add “https” at the start?

Hi Thinh, thanks for checking this out. Yes our workaround solution now is to use a link component for it as the image version doesnt work specifically for the ios devices we tested.


Using the same setup as you I was able to click the link.

By any chance can you send over some screenshots on how you are configuring that screen? Do you have any external CSS or some configurations that possibly could have affected that? I can’t click on your app’s link even with Chrome, not just iOS.