Integrations working in Editor not showing up in published app: PDFMonkey button not showing

Hi there

I’m testing out the new integrations, which are brilliant.

I’ve built a tool using the PDFMonkey integration which works perfectly in the Editor but for some reason the button doesn’t show in the published app.

I’ve tried everything on visibility and also just rebuilding the button and disabling / re-enabling the integration.

Is anyone else having trouble with the PDFMonkey button showing up in published apps?


So what type of visibility conditions are you applying to the button?

I’ve triple checked and there are no visibility conditions. If I change the same button to something arbitrary (e.g., change the action to “Go Back”) then it displays in the Production App, so it seems to be something particular to the PDFMonkey integration?

I have also tried doing it as an Action as opposed to making a button directly with the PDFMonkey plugin which has the same effect.

Is it looking for data in a row that it doesn’t have access to, or a table that has no rows?
Check carefully for row owners.
Check that you are logged in/viewing as the same user in both cases.
If you can’t figure it out, provide screen shots so extra eyes can look - maybe we can see something that you’re missing.

Thanks for helping!

I have tried creating a new app, using the Glide Company Directory template, to see if I could get the issue to repeat there and I have the same problem.

Here’s a few screenshots from the quick demo app.

PDFMonkey Configuration

PDF Monkey Visibility Settings (nothing blocking)

PDF Monkey button in Editor view (same user as I logon as in Published version)

PDFmonkey button missing in Published view

If you click “Add value” under filename does it show up?

No, unfortunately not. I’ve tried passing actual values and placeholders. Everything works as expected in the Editor view and then it just doesn’t show up in the published app.

Maybe it’s a glitch with the PDFMonkey integration? Can anyone else make it show up in a test app?

Just to add some extra context from my testing…

Even if I add PDFMonkey as a step in a longer Action it’s not working.

Interestingly, the button will show up and appear to perform but just skip the entire PDFMonkey step.

(In this case, the button creates a new row in the “Contracts” table, waits 3 seconds, then pulls the relevant information to send to PDFMonkey). In Editor mode, it does everything (adds the row, creates and returns the PDF) and in the actual published app it creates the row and skips the PDFMonkey step and goes straight to the end notification (displaying “Contract Generated”).

If it’s not too much of a hassle to rebuild the template, I would suggest trying @Rupert 's DocsAutomator integration. He’s pretty responsive in this forum.

1 Like

Thanks — I’ve just finished rebuilding using Zapier and returning the permalink from PDFMonkey which works for now as expected, although direct through the integration would be better!

I’ve filed a support ticket and the Glide team are looking at it so will update here with the result.

Thanks again

1 Like

Thanks a lot for the shoutout @ThinhDinh !

@mwc Glad you got it working. Make sure to also checkout DocsAutomator in the future and compare the solutions + let me know what you think! :slight_smile:

1 Like