Button not showing up


I have added a button to my app and its not appearing on my phone?
Until now, all changes I made were almost instant…I have been waiting for over 30mins, tried reopening the app and even uninstalling and installing again… no joy.

Any help would be appreciated!

Has this been resolved for you? Did you turn off “auto-publishing” by any chance?

I am on the free version currently and can’t change that…
Other changes are reflected immediately.
Still no button today :frowning:


What does your button do? What actions are tied with it? Do you have any visibility condtions?

Button calls for “show share options” which is tied to a column. There are no visibility conditions.


Correction - ties to details from a template column if that makes a difference


Can you attach two screenshots - one of the button being visible in your builder, and one with it not visible on the real device?

So I noticed this today (this morning) and again now…
The button has disappeared from the builder…

I re added it again this morning and it’s gone again.


If you can record adding the button in the builder, then open the real app to check if it’s there or not then it would help this debugging process. Any images or a Loom record will help us understand the situation much better.

how do i upload a video? I have an MKV file

Here is a link to the video: WeTransfer

It is not covered in the video in the right-hand side of your screen, but I assume you’re adding a button with a show sharing options and link it to a template column right?

I try accessing your app and don’t see that button, is your template column filled correctly?

So at this point and after some testing, it appears the app is not saving ANY of my changes.
I tried adding the default button, leave to dashboard and back → gone. same with another text field and separator
nothing is saved…?

Might be worth duplicating the app and if it keeps happening please support a ticket here.


if I duplicate, adjust and then publish, is there a way to keep the old url since users are already using it? Or do I have to now redistribute the new url?

after duplicating, adding the button and publishing - it works.
Back to my question about the url…?
thanks for your help on this

I believe you can change the old app’s URL to something random, then copy the old URL to the new one. It will take a bit of time to adjust that so give it some minutes to try again after changing URLs.

thanks for all your help!

1 Like