Can't add button or make switch work

I added a new button to a layout, and it shows in the list of components on the right side, but nothing appears in the builder. It actually acts like there’s a visibility condition that hasn’t been met. I also added a switch and connected it to a boolean field, but the switch won’t react when I try to click it.

Is anyone else seeing these types of issues?

1 Like

Is your details screen on a row? If you add a text entry component, is it grayed out?

I think I fixed it - there WAS a visibility setting I didn’t see.

1 Like

I’ve been seeing this a lot. I haven’t completely figured it out, but it seems to be something to do with the action that’s assigned to the button. First few times it happened, it made my head spin. Then I discovered that if I change the action the button “magically” appears. Next time it happens, I’ll pay a bit more attention and see if I can figure out exactly what’s going on.

1 Like

It could be related to that. I’m working on an action that clears a column to update a list of drivers who are working - turning a field from true to false. It’s be great to be able to clear the whole column, but all I can get to work is a series of “Clear Column” commands until the whole list is complete.

hmm, could a Single Value column help you out there?

That’s an interesting idea. First though, this behavior has got to be a bug.

I just created a new tab with a new relationship, and a new inline list, and can’t add a button. It shows in the component list, but not the builder.

@Mark - any ideas?

It looks like a button won’t appear until you go into FEATURES and assign an action that the button can actually perform. Until then, it acts like there is a visibility condition that hasn’t been met.

yeah, that’s what I’ve been seeing. But it doesn’t always happen. Must be something to do with the default action that’s assigned to a new button - could be that the new custom actions feature is causing some erratic behaviour there, @Mark ?

Tim,

Is there any way you could create a simple test app where you can get it into the no button appearing state and then send a support link to support@glideapps.com with the link. I’m not able to reproduce what you are experiencing.
Thanks,
George

1 Like

I can’t duplicate the issue in a different app, I even tried to mimic the inline list I have on the page in question.

I did send the support team a link to the app I’m having trouble with, and how to duplicate the issue.