Button and switch not showing up when connected to certain tabs in project

My App/Pages support link:

[type or paste code here](https://go.glideapps.com/support/a401abc2-013f-4457-b7a7-22d30949eb29)

Describe the bug:
I tried implementing a dropdown filter which I tested in a demo app where it was functional. When I first used it in the final project (with wrong source tab) it worked as intended but when I copied over the same settings (adjusted to correct parameters) in the second version the button doesn’t show up. Additionally it seems like this is related to switches as when trying to add a fresh switch to the page it also fails to appear.

  • shared project (viewer doesn’t seem to affect issue)
  • bug with “set column value” action buttons (Year 1) or switches in Home v.2 (works as intended in Home v.1 and other -demo- project)

Expected behavior:
Button should show and hide certain content but when selecting action for the button, it disappears. Switches also don’t show up.

Link to demo recording:

[type or paste code here](https://www.youtube.com/watch?v=bwxF1vIErX4)

I don’t think your video showed the Homeglide table. Do you have any rows in that table? I’m guessing your screen is not attached to any rows of data, so the set column action would not have any row to set.

You can verify that by navigating to that screen and then click the Data button in the lower left corner of the builder. That will show you which row the screen is attached to.

1 Like

Hey Jeff, thanks for the reply!
Indeed, when looking at the data in layout view it is empty, however when looking at data editor view you can see that there are multiple cells filled in (rowID, filterSwitch is checked to which the non-visible switch automatically connects, etc.) at the same time. Not sure what the issue is in this case.

Are you positive that you don’t have any filters on the screen? Do you have row owners applied to any column in the HomeGlide table?

Hey Jeff, made a dumb mistake, I copied the Home v.2 tab from v.1 and that carried over of course the filter data but with the different source table. Thank you for your help anyway, now all should be fine!


This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.