Install on Android


does someone also have a problem to install a Glide App on Android?
For previous apps, there was (in Chrome) an option (3-dots-menu) to install, but this seems to have disappeared now (*)
In the hamburgermenu of the Glide app itself, there’s an option “install app”, that shows a popup at the bottom to install it, but it’s not possible to hit the install-button.

Also tried with other Android-browsers, but same result.

(*) Note: there’s is still an option to add to the homescreen, but this results in a button with the chrome-icon, so a shortcut, not an installed app.


(just to compare: I build a very simple test-app with DrapCode and when opening on Chrome, I get automatically the popup at the bottom to install the app. So I think there’s nothing wrong with Chrome itself, but maybe in some settings in Glide ?!)
(*second: a simple Glide Page gives me automatically the option to install on Chrome).

Conclusion : I think something is going wrong in the settings of my Glide App. For those who want to try: (I made it open for everyone to copy the app and sheet)

Android Chrome here. I got the popup.

I get the Install option in my chrome menu.

It installed normally.

I would double check to make sure the cache and any permissions are completely wiped for that url.

I noticed the install option in the hamburger menu. Based on my understanding of PWA’s, a button in the hamburger menu seems pointless, unless for some unknown reason, the install popup was never shown in the first place. As I understand it, the install popup is controlled by the browser. There are ways for glide to delay it, but once the popup to install has been displayed and accepted or rejected by the user, there is absolutely no way for glide to trigger it again. The user would have to clear the cache and reset permissions for the site themselves. Only then will the popup retrigger. As for the hamburger menu install button, I get the same non-responsiveness too, but that’s after I already rejected the install popup, so I don’t know how they could get it to work properly…unless there has been some recent chrome changes. Regardless, installing from the chrome menu should always work under normal circumstances.


Thanks Jeff. After clearing both data and cache in Chrome, I could install the app.

Good to know :wink: