Inline List records not showing on screen

I created an experimental app as a sandbox to build options for new functionality requested by a client. The “Lab” app worked well and successfully showed the client options.

In replicating the changes from the Lab app into the legacy app, I encountered a problem. There is a Jobs sheet that simply captures a Description and Begin Date (along with a Job ID#, etc.).


There is a one-to-many relation with a JobAllocations sheet, which associates Customer Codes with the Job, for up to five Customers.

After one or more Customer Codes have been assigned to a Job (via the Job Allocations relation) an Inline List shows the Customers associated with the Job. That works in the Lab app.

It does not work in the legacy app. I have placed both apps side-by-side on dual monitors. Both Inline Lists are configured identically.

The records for Customers allocated to the Job show up in the JobAllocations table in the Glide Data Editor (with Job ID# relation values), but they do not show on the screen where Inline List is located in the legacy app. There are no visibility restrictions for this component in either app. I have tried both Inline List and Related List components with no luck.

Any thoughts? Thanks for any ideas.

Did you also add the relation columns in the legacy app?

Do you have any row owners?

Yes. The Inline List is configured to access the Job Allocation Relation.

I have the User Email column as a Row Owner field in the Jobs sheet.

So row owners are enabled in both your legacy app and sandbox app? Usually when there’s a mismatch like this either it’s a bug or some problems with row owners.

Ok, so the sandbox app doe not have any row owners. And that is the app that does what I want it to do. This is the Jobs sheet in the sandbox app. Notice the User Email does not have Row Owner enabled.

I am going to disable the Row Owner function in the User Email column for the legacy app. This is what it presently looks like.


From the Data Editor I removed the Row Owner function from the User Email column in Jobs sheet of the legacy app. Prior to doing that, there were 307 records in the Job sheet. Once I removed the Row Owner property, the list of records shown was 2 - the Jobs that had been created today.

After a brief panic, I noticed that the original records are all in the Google Sheets Jobs sheet. I don’t know how to repopulate the records displayed in the Data Editor. I have refreshed using the synch button, to no avail.

Any suggestions? This is live data. I need to make things whole again.

So after removing the row owner you can see no data in the Editor? Do you see them in the real app?

Yeah, I’ve seen this happen quite a few times. Freaked me out the first time it happened - removed row owners and every row in the table instantly vanished :scream:
Spreadsheet not affected, and I’ve never had the presence of mind to check if there is any impact in the app (I doubt it).
Usually takes a full refresh of the browser to get things back to normal.

1 Like