Inline list - empty row is visible for another user

Hi everyone, I have problem with empty rows in inline list component. If a user add some new data, another user can still see some empty rows. How to set the component to remove empty rows in another user’s screen? Screens attached

My guess is that you have Row Owners applied somewhere.
Can you provide a screen shot of the table that is the source of the list, from the Data Editor when viewing as the 2nd user?

Question: Should User B be able to see the data entered by User A, or should each user only see their own data?

here you are another screen, users can’t see their data, user B see only empty rows

I see.
You’re saving those to User Specific columns - I assume that is deliberate?

So the problem is that rows have been added by the first user, but because the columns are user specific, the second user sees empty rows.

The simple fix is to apply a filter to your inline list component, so that only non-empty rows are visible. Something like “where fixed costs is not empty” should do it.

But - the approach you are taking is a little unconventional and could lead to other problems. So I’d be curious to know a bit more of the bigger picture of what you are doing. There is probably a better approach to this that we could help you with.

Thank you for your attention, I’ve just checked similar to mine app Personal Budget Tracker by Glide and I see that list component was used to entry new data (i.e. expenses) instead of inline list. I will use it too and check is any new problem will appear.


I’m not familiar with the template, but for a use case such as this where you want to have multiple users and you want to keep each users data private, the best approach is to use Row Owners.

The way that would work:

  • Change what you have now to use normal (not user specific) columns
  • Add an extra column that will contain the users email address, and make this a row owner
  • When a user adds a new item to the list, add their email address to that column using User Profile Columns

With that approach, each user will only see their own data, and there will be no need for any filtering on the list.


I’ve changed the settings follow your instructions, but now no data is visible even mine:), should I set some action On Submit in add component?

mmm, your column settings are messed up.

  • You have row owners on your fixed cost column. That setting should be on the user column.
  • It looks like your value column is still user specific. You should delete that column and create it again, and make sure you don’t tick the user specific box
  • And your user column is empty. This means your form isn’t adding the user email. You need to add that to your form screen:

also, i think you are missunderstanding what row owner is… it blocks the row, not the column… depending on the email in the row owner column or columns array

thanks a lot, it seems right now it works

ok, powodzenia, jak cos to daj znac…

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.