Inline list not updating

Hi there,

The content of my inline list sometimes doesn’t update to the latest data.

As you can see in this video :

  • initially the inline list show the same items for 1 and 2, and 3 and 4
  • when I duplicate the list, it displays different content
  • once I delete a duplicated list, it displays the right items for each step

That looks like a bug to me.
Here is the support link to the app.

Has anyone identified this bug and found a work around?
Maybe there is a way to force the update of the list?

Thanks for your help!

It looks like the list doesn’t update if the previous dataset was the same size.
If I add a fake item in step 2, it refreshes correctly.

It seems like you have only one inline list and set it to show different items based on what the button sets to a user-specific column?

This has been reported multiple times. The inline list does not recalculate correctly when you set it up like that, and I’m not sure if there has ever been a fix. My workaround is to have multiple inline lists and use conditional visibility, but I understand that it would not scale well.

Thanks for the answer @ThinhDinh.
Yes, this sounds like my issue indeed.
It doesn’t recalculate correctly when the data set is the same size as the previous one.
Looks like the refresh detection considers the length of the dataset instead of a checksum.

Thanks for your workaround.
I’ve just tried using 2 lists and a visibility based on modulo, but it doesn’t work.

Any chance you could direct me to the correct thread?
Maybe I could find some other ideas.

Thanks for your workaround.
I’ve just tried using 2 lists and a visibility based on modulo, but it doesn’t work.

Actually, that works

1 Like

Yeah, that is the only way to make it work reliably at the moment, I think.

I was going to post a glitch but saw this. Is this somewhat of the same issue?

The first inline list doesn’t update properly when “show see all for more than X” is enabled. It is slower to show up and doesn’t delete itself until you leave the screen and come back. Data being sent through API. If the “show see all for more than X” is not enabled, then it works no problem. Weird thing is, if you put two of the same list after one another, the second one works fine. The first one doesn’t.

That’s weird that number 2 works, I would have expected that both don’t work, or take some time to be updated. I would submit that to the support team.