Inline list form Dynamic table displayed in builder but not in deployed app

Describe the bug:

  • In-line list linked to a dynamic dynamic glide table is displayed correctly in the builder but not deployed app.

Expected behavior:

  • The inline list is populated in the dynamic table, so it should be displayed in the inline list in the deployed app as well.

How to replicate:

  • This glide table is shared between 2 apps, but doesn’t have any input columns (just calculations, single values & relations)
  • This glide table is dynamic: transforming a row array to columns (using single value and finding index). The original array is a split text from a javascript column returning a string.

Link to demo recording:

It looks like you are creating dynamic relations using dates.
My guess would be that it’s failing in the published App due to a date format mismatch.
This is a common problem.
My suggestion would be to try converting all dates to integers for the purpose of using in relations.
This can be done with a math column using the following formula:

Year(Date) * 10000
+ Month(Date) * 100
+ Day(Date)

The above will give you an integer representing the date in YYYYMMDD format.

Give that a try.

1 Like

Hi Darren,
Thank you for your quick answer.
I’m not using relations only single values, then split the single values into dates.
But when I display another value instead of the date (e.g RowIndex), it still doesn’t work.
See below:

I assume not, but do you have any filters on your inline list?

Can you show how your single value columns are configured? Where does that data come from? Is it a user row, or another table? Just trying to make sure that the data row, that’s the source of the single value columns, is always the correct and expected row. I assume it is since it’s populating on the back end, but just want to make sure.

Lastly, there used to be an old issue where some inline lists would only display once you start scrolling on the screen. Can you try scrolling to see it the list shows up. You may need to add additional dummy content to the screen, which goes past the end of the screen, to assure that scrolling is enabled. This is just to test to see if that’s the issue, or if it’s something else.

I had a filter (to not display the rows with empty results).
If I remove the filter and just display RowIndex, it works. However, if I try to display the single value column (from the first row of my Helper-Table), the single value column doesn’t display. If I add a filter, then no data is displayed (like in the first video).
See here:

Note: the same exact configuration works in Pages, not in App

Nothing is standing out to me. You are using a helper table with one row, so it’s safe to say that everything should be coming into the AvailableTimes table just fine…and you proved that when viewing the editor while working with the published app.

The only thought I have is that the screen finishes rendering before everything finishes calculating in the AvailableTimes table, and before the filter can be applied. The filter may be seeing blank values before the screen finishes rendering.

Have you at least tried the scrolling thing that I suggested above? That was an issue in the past, but I want to at least rule that out. (That’s of course with your filter in place.)

It may be worth adding an IF column that only returns ‘true’ if the extracted slots column is not empty. Then create a template column with the value ‘true’ in whichever table drives that screen, and create a relation that links the template ‘true’ value to the IF column in your AvailableTimes table. Not sure if this will make a difference, but the fact that you use a relation instead of directly using the table for that inline list could maybe make a difference.

1 Like

Hi Jeff,
Thank you very much for your help.
I tried to scroll, still not working.

I tried your suggestion with the IF column (what I understand of it), still not working.

However the screen shows the list of items, without its content (unless I choose to display RowIndex), so it looks like it is a rendering issue?

And if I add a filter to check column it he column is not empty, then there no rendering at all. So it seems that there is a problem displaying and filtering that single value column (or even more relation) pulling the data from the helper-table.