Images don't show up on the app

Hi everyone!

I’m an absolute beginner to Glide and I have been trouble shooting for while now with the images don’t showing up in the app.

Screenshots of the data in Google sheets and the app attached.

Hope someone knows what’s wrong. :slight_smile:


It looks like your URL isn’t actually pointing to the image itself.

For example when I go to the first URL:

It occurs to me that the link must be the below.

You must right-click on the image, then copy that image link instead of using the link like you currently have.


Thanks ThinhDinh! I’ve tried to have the links ending with .jpg, pointing at the image as you wrote. Maybe I’ve saved the wrong link ending with .jpg. I will try to right-click and and copy that link.

Sometimes there seems to be a lag in the updating if the data changes in the sheets. Maybe that’s what’s occured. At some point I had the right links but the app didnt update. Anyway, now I now what’s supposed to work and I will try again. :slight_smile:

Thanks for your answer!

1 Like

Let us know if it works or not, we’ll try our best to help :wink:

It worked perfectly when I saved the .jpg right-clicking the image!

Thanks for helping a newbie out! :grinning:

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.