I want public with email

but the settings don’t show up on my page

Which screenshot is referring to your app? It’s different depending on if you are using an old team folder or old pricing plan compared to a newer team folder and newer pricing.

I see Public options on both screenshots, but neither show that you have selected Public.