How to remove “My Talks/Favorites” from Calendar view

On my schedule view, I can’t figure out how to edit or get rid of “My Talks” that shows a signed in user the schedule items they have favorited. I’m trying to figure out if this is something built into Glide or something that I inadvertently copied over from a template. I think I started the app I’m using from a copy of a version of the advanced conference template that Glide has available.

One option is to remove favorites, but I assume you don’t want to do that. The other option is to change your screen layout to a Details style layout, remove all components on the screen, then add only an inline list with the Calendar style layout that references your calendar table.

In this case, I actually don’t need the favorites at all. But when I went into the data editor it won’t let me delete that column. I must be missing the correct place to remove it.

I’d also be more okay with it if I could change the text to something other than “My Talks”. Is that editable somewhere? For my use case, the calendar events are only occasionally a “Talk”.

Do you have a favorites component in the details of each list item? Usually you can remove the favorites component and that will make the favorites tab go away. Also, that is where you can change the name of the tab… through the component settings.

1 Like

Thanks, that answers a big part of it. That was something that had been copied over from the template that I didn’t realize. I removed that component, but it’s still on the overall view. However, the name did change back to what I assume is the default “Favorites”. I’m not sure why it didn’t go away completely.

Can you try adding the favorite component again in the details view, then delete that and go back to see if it is cleared?

Also make sure you did not accidentally favorite any of the events.


I checked all of the users and one person had favorited a few events. I unchecked those events for the user.

I added the component back and removed it, but “All” and “Favorites” is still listed at the top of the screen.

Weird, last resort option is to duplicate the app and do all the steps above. I’m not sure of a further workaround.

Could also try deleting the isFavorite column, but I feel like that’s caused some problems for people, or completely disabled favorites forever. Worst case I’d probably just build the table and screens from scratch without favorites.

Otherwise switching the tab to a details layout with an inline list would work too, but you might lose the floating button.

1 Like