How do I disconnect Excel Account/re-establish link to synced Excel Sheet

I ran into an issue being able to sync my Excel file when I had to delete One Drive from my Mac and reinstall. After the reinstall, it is no longer syncing in my Glide app. I want to try disconnecting and reconnecting my Microsoft account but I do not see how to disconnect it so that I can start over (or perhaps there is another way to solve this issue?). I tried 1) adding a different Excel file in case there was corruption in the first one 2) Reauthorizing my One Drive account. 3)unlinked the sheet and deleted the tab layout using the Excel data 4)deleted the sheet, 5) tried installing new Excel sheet and got the message “Having trouble connecting to Data Source” So, I have no way to add new Excel Sheet nor delete current sheets, nor uninstall - reconnect the account in integrations. Kinda stuck at this point.
CleanShot 2024-05-16 at 09.09.29
CleanShot 2024-05-16 at 09.12.48
CleanShot 2024-05-16 at 09.31.37

I tried deleting the empty rows of the source file to no avail. I also tried just connecting a different Excel file altogether. Still no luck. It says “Failure to connect to data source”. After 6 hours I am throwing in the towel. Emailing support…

1 Like

That’s weird if a standalone One Drive app delete would wipe out your connection in Glide. I would be interested to hear what the support team says so I can alert my clients not to do that in the future.

I asked for help from ChatGPT tonight, and she suggested trying a different browser. When I did that, I was able to sync with a new One Drive account, but not with the original account. It’s strange because I’m not sure if it was really a browser issue or not. The strange thing is that the new One Drive account won’t sync in the Brave Browser, but it will in Chrome. This doesn’t make much sense because according to that logic, the original One Drive account should also sync in Chrome. Additionally, when attempting to sync, there were three One Drive libraries appearing in the original One Drive account. I suspect the problem is related to this, possibly from installing from a Windows store download and then trying to install from a Mac App store download when the first attempt didn’t work. The best next step to test would be to remove the original One Drive from my Integrations, but I can’t find a way to do that no matter how hard I search. I will update this post once I hear back from support for future reference of anyone who has this issue in the future.