Excel connection error

Hi community!
I have trouble connecting/updating any Excel file (from personal OneDrive/Hotmail account) as a new or extra data source in my Glide Apps/Pages. I managed to do that without any trouble for a long time ago in a few of my earlier prototype apps, but when I now try to do that inside an existing Glide Pages, I get this error:

Oh sheet!

There was a problem linking the data source

When I try to create a brand new app or pages (to see if that would make a difference), I get the following error.

{“error”:{“code”:“AccessDenied”,“message”:“Could not obtain a WAC access token.”,“innerError”:{“date”:“2023-03-19T14:40:19”,“request-id”:“4b6ab7d0-8e49-480f-ad5e-121d75e9f27a”,“client-request-id”:“4b6ab7d0-8e49-480f-ad5e-121d75e9f27a”}}}

I already went to my Microsoft account and removed the Glide permissions and then re-installed them later, cleared browser cache, tried incognito, etc, but I keep getting this message, with several Excel files (different accounts even) and several apps/pages. I google “WAC access” but could not get much further with that info.

When I try and update existing Excel connections (that I could install and refresh without any trouble until a while ago) give the following error:

Oh sheet!

Glide could not reload the sheet.

I am on a non-profit plan. I already tried the support chat (chat GPT) but none of these advices work (see above) and the chat referred me to support@glideapps.com but they can’t help me because I am on a non-profit plan and referred me to this community. I have been following many interesting posts and advice on this community before, so I hope one of you experts, can advice me on extra tips and workarounds to get the Excel connection to work again.

I even created a brand new Glide account to see if that would help, but during the setup process, I get this error at some point:

Oh Sheet!
Microsoft Graph returned improper credentials

FYI: Google sheets as connection works fine. I also connected Airtable without any issue, just now with Excel files I get these errors. I tried connecting a brand new Microsoft (outlook.com) account too, but that gives me the same errors. I tried everything in Google Chrome and Safari (working from a Macbook Pro, MacOS ventura).

I hope you can help me solve this!



Thanks for reporting this issue! It helped us to investigate the root cause.

As this issue is affecting several Glide customers, we have escalated and are reporting on the incident via our status page. Please watch that page for additional updates.

1 Like

Do you this SYNC issue involves more than just connecting to the Excel Tables? In other words, do you think it will also resolve the issues with disappearing data from Excel spreadsheets where the rows (including the RowID) persist, but one or more columns are gone?

Thanks for the quick reply! Glad to see it’s not me :wink: I’ll stay tuned!

Hey @Bas! We fixed the Excel issue. Thanks again for flagging.

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.