Home screen popup not showing

In one of Glide’s recent updates on Twitter, thet said:

“Now, when you open an app link, you’ll see a popover with easy-to-follow installation instructions, making it simple to add the app to your device.”

However, I do not get a popup with the download instructions. Neither in “Classic” apps or when I build a new app.

Anyone experiencing the same?

Which browser do you use?

Safari. Chrome. Doesn’t work on any of them. On an iPhone 12 iOS-version 16.3.1. :slight_smile:

I believe only Safari on iOS and Chrome on Android will support installation of PWA apps. If you are using an iPhone, I would recommend using Safari. It’s possible that the notification may have been dismissed, but you still should be able to manually install it.

If you are on iPhone using safari and want the pop up to come back you could delete the app bookmark and clear your safari cookies.

After deleting the app from home screen goto settings → safari → clear history and website data

This will return safari back to its initial state before you ever installed a glide app. I’m not suggesting your users should do this but it’s useful to troubleshoot your issue.

If the pop up still doesn’t work after that then there’s probably something else going on.

FYI clearing you history and website data will remove any saved passwords within safari… i.e. you’ll have to sign back into this community.


Thanks for the suggestions. However, I cleared my history and website data on safari and it is still not working.

Tried on another iPhone as well. Same issue, no popup showing.

Tried another app as well (also build on Glide). Also no popup showing there.

Any other suggestions for what to try and/or how to move forward from here? It’s really critical that the prompt shows to my users who are unaware of the PWA ‘download’ method.

@Jeff_Hager, yes indeed it can be done manually. But all my users may not know how, so I would like to show the prompt to them.

I was able to reproduce. iphone on 16.4

Please submit a support ticket

1 Like

Thanks a lot, Eric.

However, my app is not yet on a paid plan (only personal). So it says support cannot help and I am being told to ask in the community.

How do I then submit a bug?

I have told the support team about this thread. Will update you accordingly.