Glide page doesn't update the gsheet when I use add function

I’ve used Glide 2 years ago and had no similar problems. Now I would use the page version, but in the case of the add action function, the google sheet is not updated (there is no new record). If an existing record is modified from Glide, the update runs fine. The new added record is visible inside the Glide, but not in the table. I tried closing it and leave open the table, but nothing happened. Snyc setting is on normal and I am far from the 1000 update monthly limit. What could be the problem?
Thank you for your help

Have you tried scrolling to the very bottom of your google sheet?

There are only 4 record :slight_smile:
This would have been the fifth

So nothing at the very bottom of the sheet?

Oooo, you are right! :slight_smile: Thanks!
The added record is on line 50472. Why does it work this way?

You are most likely using an Arrayformula. That makes all rows populated rows (even though they may seem to be empty) so glide will not overwrite them. What’s happening is it’s adding a new row to the sheet.

Delete all of the rows that are empty. You should only have 5 visible rows in your sheet.


Yes I use arrayformula (exp. arrayformula(F2:F) . I deleted the empty rows and it’s working right now.
Is it advisable to enter a fixed value in the arrayformula 2nd parameter exp: arrayformula (F2:F100)) ?
Thank you for your help! :pray:

1 Like

No, you would have the same problem if you used a fixed value. The way you have it with F2:F is better since you’re not limiting your formula to a certain number of rows.

Ideally, if you can replicate the same formula using Glide computed columns, then you don’t have to use a sheet formula, and you won’t have any delays waiting for the sheet to re-sync with Glide.

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.