Glide doesn't load a G. Sheet

Suddenly, why is there only one sheet not loading data from the G. sheet while other sheets can?

  • Have you tried refreshing the sync in the data editor?
  • Did you change something to the buggy sheet recently?
  • If the sheet happens to be new, is it structured correctly with at least one column and a column header?
  • Have you tried adding a new sheet to see if that new sheet syncs with Glide correctly? If so, maybe you could move over the data to the new sheet that’s not buggy.

Since I’m using importrange I added one definite title in case the title fails. Is this the cause? But it’s been working for a quite long time. Any idea how to fix it?

Yes, that’s a common issue with importrange.
Adding a static header row is the way to fix it.
Although I see you have the header row duplicated. What I would suggest is modifying your importrange formula so that it ignores the first row. ie. start the range at row 2.


Yes, the first line is the static header. The second line is an importrange starting from the first line/title of another sheet.
So you mean the second line doesn’t need a title anymore?
I’m just worried it will be deleted.

Just change your importrange formula. Instead of A1:..., make it A2:... and then put it in A2

Now the only way is to create a new sheet again, no other way to recover it again?

I don’t understand. All you need to do is fix your importrange formula and re-sync the sheet with Glide.

1 Like

If you’re uncertain about Darren’s recommendation, you can test it on a test sheet first.

My first title is already static. The formula is also in A2. The difference only takes the title or not with importrange.
I don’t understand the problem. Does that second title interfere with glide identifying it?
I’ll try later.

It could interfere, especially if there’s an incidence on the type of data (text vs number vs boolean for instance) because the structure of a table that can be used as a source of data in Glide is as follows:

  • 1st row in the table: column headers
  • Subsequent rows in the table (2nd row and beyond): records

The 2nd is not supposed to be a repetition of the first.

Thanks, for your explanation.

Now it’s suddenly back to normal again after I stayed out for a while and haven’t changed it.

Thank you too @Darren_Murphy