Glide data sheets

Hey community, i ran into some problems with my sheets its like their locked. I click on them and i can’t edit inside of it. Some columns i tried to delete as well as rows and it doesn’t delete.

are you sure these are Glide sheets? not google sheets or Airtables?

Yes, their glide sheets. It’s like their locked. I check the row and push delete it does nothing. I click the cell to enter something in it does nothing.

Can you provide a screen shot or a short video please?

i’m unable to provide a video at the moment

Have you had time to record a video with Loom. We would like to know more about the situation. Thank you.

Couple of things to clarify here:

  • Nothing is locked up. Everything is working as intended.
  • Relations don’t contain values. They just show the related records based on how you configured the relation. You can’t add, edit, or delete the contents of a relation. You can can only change the configuration of the relation and change the values that it is matching. To configure a relation, you pick a column in your table and link it to a matching column in another table. If there are matches, then you will see those related rows in you relation column.
  • You can’t merge multiple relation columns together. Each relation serves the purpose you configured it to do.
  • The relation in your last 2 rows is matching blank to blank in the related table. If you want them to go away, just delete the empty rows.

As far as solving your problem, you have a few options.

  • Move all of your related content into one table and use one relation.
  • Or, create separate relations, but add multiple lists/collections to the screen. One for each relation. Collections will only display if the relation is not empty.
  • Or, change the action on your main list to a custom action, and add multiple IF branches in the action editor to go to different screens based on the chosen item in your main list.

As @Jeff_Hager said, relations are just pointers into your data.

For the first issue, you said, you had relations and they are showing in your list, and that is because you selected “relations” as your source.

For the second one, nothing is showing in your list because you have “relations” selected as your source, but your pointer that points to the sheet with data is “rel_actors”. You need to select that as the source for your list.
image <<-use this

Not “relations”

As far as deleting, as @Jeff_Hager said, you cannot remove those relations from the last two…, simply select the entire lines 12 and 13 by checking the checkbox at the beginning of the line, and you will be able to remove the empty lines.

1 Like

Check the boxes, and then hit the ‘delete’ key.

Your relations are fine, if you want actors listed separately from the other, you just had the wrong relation selected for your second list.

Thank you

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.