Filter Data not working correctly?

Dear All,

Can anyone please let me know why is March, April and all the following months showing? It is showing the whole January, no February, then 1st of March, 1st of April and so on …

My filter is Month No. equals 1, which is only January. So by right it should only show the month of January. Imma so confused.

Thanks in advance :smiley:

I wonder if it’s because of the format of the number. What does this column look like in the Glide editor? Is it a number?

Is there a preceding space in the Month Number?

If you don’t need that column in the Sheet, you can have a math column to handle that.

MONTH(D) with D being the date column.

Then try the filter again.

its a number column. and no spaces

tried it, still didnt work

Can you show a screen shot of that table as it appears in the Glide Data Editor, please?

Please ensure that the column headings are clearly shown in the screen shot.

Here you go

And when you use either of those Month No or Math columns as a filter on an inline list, it doesn’t work?

Sorry, I can’t explain that. I just tested a similar setup to be certain, and it works perfectly.

1 Like

Please confirm that your math column is using the date column to extract the month.

I suspect it’s the dates. It’s probably interpreting them as dates in MM/DD/YYYY format. This is especially a problem if you manually enter them in a google sheet. If you change the format of the date column in the glide data editor, it will become more apparent.

It’s been a long time since I’ve seen this problem with data coming from a google sheet. I don’t remember if changing the format of the column in the google sheet made a difference or if changing the region/locale in the google sheet settings did anything.

If dates are not coming from glide and they are manually entered in a google sheet, I would make sure they are entered in MM/DD/YYYY or better yet, YYYY/MM/DD format. Since you aren’t using a full standard ISO formated date, then glide has to guess if your date is written with the Day first or the Month first. It doesn’t always guess correctly.


You were right. I only had to change the date column from Short to Medium, and made sure all the dates were correct, and it worked perfectly :partying_face:


This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.